Bug 51925 - [Xamarin-Profiler]:Accessibility:MAS36: Windows: Keyboard: In "Inspector view" section the "Pie slices" of the "Pie chart" are not accessible with keyboard.
Summary: [Xamarin-Profiler]:Accessibility:MAS36: Windows: Keyboard: In "Inspector view...
Status: CLOSED FIXED
Alias: None
Product: Profiler
Classification: Xamarin
Component: Windows (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: 15.6
Assignee: Sergiy Velychko (Global Logic)
URL:
Depends on:
Blocks:
 
Reported: 2017-01-28 11:20 UTC by Dona Venkata Jaswanth Kumpatla
Modified: 2018-04-23 12:23 UTC (History)
8 users (show)

Tags: accessibility, wipro, xamarin-profiler, a11ymas, mas36
Is this bug a regression?: ---
Last known good build:


Attachments
Please find the attached screenshot (286.42 KB, application/x-zip-compressed)
2017-01-28 11:20 UTC, Dona Venkata Jaswanth Kumpatla
Details
Fixed-51925 (138.90 KB, image/png)
2018-04-23 12:22 UTC, Ramya Sri Narasinga
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description Dona Venkata Jaswanth Kumpatla 2017-01-28 11:20:01 UTC
Created attachment 19607 [details]
Please find the attached screenshot

Testing Environment: 

OS: 
      •	Windows 10.
      •	Version 1067.
      •	Build 14393.607.
Visual Studio and Xamarin:
      •	VS 2017 RC Enterprise.
      •	Xamarin For VS 4.3.0.550.
      •	Xamarin Profiler 1.0.4
Pre -Requisites: Build and Deploy Xamarin Application into Android Emulator

Repro:
1.Launch Xamarin profiler through Visual Studio.
2.From "Choose an Instrument Template" window navigate to the "General" tab and select any instruments tab from the existing "Available Instruments”.
3.Select the "Allocations" instrument tab from the "Instruments" list and select the "Allocations" tab from "Instrument Detail Area" section and navigate to the "Inspector View" section, try to access the "Pie chart" individual elements under "Top Allocation" with the keyboard in "Xamarin Profiler" window. [screenshot]
Note:
User is able to access the "Pie slices" with mouse.

Actual Result:
In "Xamarin Profiler" window under "Inspector View" section the "Pie slices" of the "Pie chart" are not accessible under "Top Allocations".

Expected Result: 
The user should be able to access the "Pie slices"   of the "Pie chart” in "Xamarin Profiler" window.

Suggested fix:
The Is Keyboard Focusable and Has Keyboard Focus must be "True".

User Impact:
users with visual and/or motor impairments who rely on keyboard may find it difficult to access the "Pie slices" while navigating with keyboard and may not use the application efficiently.
Comment 1 Luis Aguilera 2017-06-22 12:54:02 UTC
moving to 15.4
Comment 2 xamarin-release-manager 2017-10-09 11:33:14 UTC
Fixed in version 1.6.1.84 (master)

Author: Sergiy Velychko
Commit: 7a0c80cd5256fc3baa13d45104dba8eac5ece675 (xamarin/profiler)
Comment 3 Ramya Sri Narasinga 2017-11-24 08:05:45 UTC
Comment on attachment 19607 [details]
Please find the attached screenshot

The issue still exists in Version 1.5.6.51 hence reactivating the bug.
Comment 4 Ramya Sri Narasinga 2017-11-24 08:06:36 UTC
If the issue is fixed in any of the latest build please provide the path to install the same.
Comment 5 Sergiy Velychko (Global Logic) 2017-11-28 09:49:55 UTC
Works in Version 1.6.1.288 of installer
Comment 7 Ramya Sri Narasinga 2018-04-23 12:22:27 UTC
Created attachment 26269 [details]
Fixed-51925

The bug fix verified on Xamarin Profiler version: 1.6.2.145, hence closing this bug.