Bug 51920 - [Xamarin-Profiler]:Accessibility: MAS17:Windows: Color Contrast: Luminosity Contrast ratio for "Arrow mark" ,"Plus(+)" ,"Bullet Points" in the application do not match the required 4.5:1
Summary: [Xamarin-Profiler]:Accessibility: MAS17:Windows: Color Contrast: Luminosity C...
Status: CLOSED FIXED
Alias: None
Product: Profiler
Classification: Xamarin
Component: Windows (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: 15.5
Assignee: Sergiy Velychko (Global Logic)
URL:
Depends on:
Blocks:
 
Reported: 2017-01-28 10:59 UTC by Naveen Katakam
Modified: 2017-11-01 04:59 UTC (History)
7 users (show)

Tags: wipro, xamarin-profiler, a11ymas, mas17, accessibility
Is this bug a regression?: ---
Last known good build:


Attachments
Repro Screenshot. (783.60 KB, application/x-zip-compressed)
2017-01-28 10:59 UTC, Naveen Katakam
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description Naveen Katakam 2017-01-28 10:59:56 UTC
Created attachment 19602 [details]
Repro Screenshot.

Testing Environment:
   OS: 
      •	Windows 10.
      •	Version 1067.
      •	Build 14393.607.
   Visual Studio and Xamarin:
      •	VS 2017 RC Enterprise.
      •	Xamarin For VS 4.3.0.550.
      •	Xamarin Profiler 1.0.4

Pre -Requisites: Build and Deploy Xamarin Application into Android Emulator

Repro:
   Scenario-1:
      1.Launch Xamarin profiler through Visual Studio.
      2.Navigate to "Choose an Instrument Template" window.
      3.Observe the color contrast for the "Arrow mark" in the breadcrumb bar.

   Scenario-2:
      1.Launch Xamarin profiler through Visual Studio.
      2.Navigate to "Choose an Instrument Template" window.
      3.Observe the  color contrast ratio for the "Bullet Points" for selected "Allocations" tab (under Class column) at "Instrument Detail Area" section.
   
   Scenario-3:
      1.Launch Xamarin profiler through Visual Studio.
      2.Navigate to "Xamarin Profiler" window.
      3.Observe the color contrast for "Plus(+)" button above the time span scale.

Actual Result:
   Scenario-1:
      Luminosity contrast ratio is less than 4.5:1 for the "Arrow mark" against the background.

   Scenario-2:
      Luminosity contrast ratio is less than 4.5:1 for "Bullet points" in selected "Allocations" tab against the background.

   Scenario-3:
     Luminosity contrast ratio is less than 4.5:1 for "Plus(+) " button against the background.

Expected Result: 
   Scenario-1:
      Luminosity contrast ratio should be above 4.5:1 for the arrow mark against the background.

   Scenario-2:
      Luminosity contrast ratio should be above 4.5:1 for "Bullet points" in selected "Allocations" tab against the background.

   Scenario-3:
      Luminosity contrast ratio should be above 4.5:1 for "Plus(+) " button against the background.

User Impact:
People with low vision often have difficulty to identify the arrow mark that do not contrast with their background color.
Comment 1 Luis Aguilera 2017-06-22 12:54:03 UTC
moving to 15.4
Comment 2 xamarin-release-manager 2017-10-03 12:23:54 UTC
Fixed in version 1.6.1.40 (master)

Author: Sergiy Velychko
Commit: 743d9a48cc34d4a3cca3e2427d33a8e8439635c6 (xamarin/profiler)
Comment 3 Ramya Sri Narasinga 2017-10-25 12:05:34 UTC
The issue is fixed hence closing the bug.
Comment 4 Ramya Sri Narasinga 2017-11-01 04:59:54 UTC
the issue is fixed hence closing the bug.