This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 51778 - XamlC needs Portable .pdb support
Summary: XamlC needs Portable .pdb support
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: 15.2
Assignee: Bugzilla
URL:
: 52692 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-01-26 08:16 UTC by David Karlaš
Modified: 2017-04-06 12:09 UTC (History)
6 users (show)

See Also:
Tags: 2017-02
Is this bug a regression?: ---
Last known good build:


Attachments

Description David Karlaš 2017-01-26 08:16:52 UTC
Mono Cycle 10, will be producing .pdb instead of .mdb, hence using mono master with Xamarin.Forms project results in build failure since XamlC tries to load .mdb file which doesn't exist.

There are probably 2 ways to solve this.
a) Use latest Cecil with https://github.com/mono/cecil/commit/898fb6b8cb03319937448d93bdf6eaa3dd2c6008
b) Use latest Cecil with some logic in XamlC to decide which SymbolReader/Writer to set to PortablePdb or Mdb
Comment 2 Samantha Houts 2017-02-13 19:04:35 UTC
Should be fixed in 2.3.5-pre1. Thank you!
Comment 3 Lluis Sanchez 2017-02-23 10:43:41 UTC
Is this package already published? We need a fixed nuget ASAP because the XS build now depends on it.
Comment 4 Lluis Sanchez 2017-02-24 15:35:44 UTC
*** Bug 52692 has been marked as a duplicate of this bug. ***
Comment 5 Peter Collins 2017-04-05 22:00:26 UTC
We also have a fair amount of tests we'll need to update to bring in this fix, is there a 2.3.5 pre-release version available anywhere?
Comment 6 David Karlaš 2017-04-06 06:53:00 UTC
Afaik, this was later also backported to 2.3.4.
Comment 7 Stephane Delcroix 2017-04-06 12:09:06 UTC
this is back ported to 2.3.4. 2.3.4 has cecil 0.10.0-beta4. if you want to test with -beta5 you can grab any recent nightly build on myget

Note You need to log in before you can comment on or make changes to this bug.