Bug 51710 - [tvOS]Native linking failure when Linkall.app is built with fastdev enabled.
Summary: [tvOS]Native linking failure when Linkall.app is built with fastdev enabled.
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: General (show other bugs)
Version: XI 10.4 (C9)
Hardware: PC Mac OS
: Normal normal
Target Milestone: 15.3
Assignee: Rolf Bjarne Kvinge [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-01-23 16:26 UTC by GouriKumari
Modified: 2018-01-08 13:00 UTC (History)
6 users (show)

See Also:
Tags:
Is this bug a regression?: Yes
Last known good build: 10.4.0.89 (cycle9: 7f111f7)


Attachments

Description GouriKumari 2017-01-23 16:26:45 UTC

    
Comment 1 GouriKumari 2017-01-23 16:31:28 UTC
## Steps to reproduce:

Update System to Xamarin.iOS cycle9 build  mtouch 10.4.0.96 (cycle9: 4e31137).
Build Linkall-tvOS.csproj with fastdev enabled.

## Actual Behaviour:
App faisl to build with native linking error.

## Build Log with fastdev enabled:
http://xqa.blob.core.windows.net/gist/log-3a21dae412fb439ab650170bb002700c.txt

## Supplemental Info:
It builds successfully when fastdev is disabled.
This issue seems to be introduced with https://github.com/xamarin/xamarin-macios/commit/e3f2685b8e2cdb163ffd0518d108f1e687491841
Comment 2 Rolf Bjarne Kvinge [MSFT] 2017-01-23 16:42:28 UTC
I can reproduce, but reverting the test-only changes from https://github.com/xamarin/xamarin-macios/commit/e3f2685b8e2cdb163ffd0518d108f1e687491841 makes the build succeed (https://gist.github.com/rolfbjarne/f3a2f393b6c92b6634d697df1d2095ba), which proves that this isn't a regression in any bits we ship.
Comment 3 Rolf Bjarne Kvinge [MSFT] 2017-01-23 16:52:29 UTC
This is the tvOS-version (and probably watchOS as well) of bug #51548 (the fix for bug #51548 was to pass '-u _symbolX' to the linker, but '-u' is not allowed for bitcode).

@Sebastien, my suggestion here would be to bump this to C10, because tvOS (and watchOS) is much less used than iOS, so the impact should be lower (and the workaround is trivial). Once fixed, we can evaluate if we want it in a C9 service release or not.
Comment 4 Sebastien Pouliot 2017-01-23 16:54:33 UTC
I'm fine with adding a "known issue" to C9 release notes to cover this (until fixed).
Comment 5 Rolf Bjarne Kvinge [MSFT] 2017-01-30 18:13:18 UTC
For C9: automatically disable fastdev when we find binding projects in tvOS and watchOS.
Comment 6 Rolf Bjarne Kvinge [MSFT] 2017-01-31 07:25:37 UTC
I've implemented a temporary workaround for this:

master: https://github.com/xamarin/xamarin-macios/pull/1592
cycle9: https://github.com/xamarin/xamarin-macios/pull/1591
Comment 7 Sebastien Pouliot 2017-01-31 15:16:46 UTC
-> C10
Comment 8 Sebastien Pouliot 2017-03-24 19:36:03 UTC
@Rolf was that to be fixed with PR 1680 ? or did we wait for it to merge to fix it ?
Comment 9 Rolf Bjarne Kvinge [MSFT] 2017-03-27 06:29:50 UTC
@Sebastien, no, this was not fixed with PR #1680.
Comment 10 Rolf Bjarne Kvinge [MSFT] 2017-06-02 07:28:52 UTC
PR with fix: https://github.com/xamarin/xamarin-macios/pull/2162
Comment 12 Chiranjib Mukherjee 2017-06-05 10:05:42 UTC
Please provide Fix Versions and Fix Details
Comment 13 Sebastien Pouliot 2017-06-05 13:30:44 UTC
Do NOT reopen a bug unless you can reproduce it
Comment 14 GouriKumari 2017-06-14 18:46:11 UTC
This issue is resolved. Verified with latest d15-3 build

## Test Log:
http://xqa.blob.core.windows.net/gist/log-8a8946388df1424bb15cab78c286886a.txt

## Test Env :
http://xqa.azurewebsites.net/api/testresults/xi/5c3bf8f5-4b1b-4a47-95ac-913edff08751
Comment 15 Jahmai 2017-12-11 23:57:59 UTC
So, what... fastdev will never be supported if you have more than one binding project enabled? Two flagship features are incompatible and disabling one is the solution?
Comment 16 Rolf Bjarne Kvinge [MSFT] 2018-01-08 12:36:23 UTC
@Jahmai, disabling fastdev was a temporary workaround; the bug has already been fixed properly and the workaround has been deleted (see comment #11).
Comment 17 Jahmai 2018-01-08 12:38:25 UTC
Compilation was failing with an error that lead me here as of the latest Xamarin.iOS on the date I made that comment. So when exactly was that pull request released?
Comment 18 Jahmai 2018-01-08 12:38:55 UTC
Sorry, not failing, just stating it was disabled.
Comment 19 Rolf Bjarne Kvinge [MSFT] 2018-01-08 13:00:45 UTC
@Jahmai, sorry, I was confused, this bug refers to a somewhat different issue than what you're running into, and we ended up talking about different things.

You're running into the workaround for bug #52727, which has not been fixed properly (the workaround is still in place). I've filed a new issue (https://github.com/xamarin/xamarin-macios/issues/3174) for us to look into fixing this somehow.

Note You need to log in before you can comment on or make changes to this bug.