Bug 51687 - WebApi Request work but Response return nothing
Summary: WebApi Request work but Response return nothing
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Net.Http (show other bugs)
Version: master
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-01-21 17:29 UTC by Lorenzo Delana
Modified: 2018-03-13 13:59 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
repro working copy (34.19 KB, application/x-zip-compressed)
2017-01-21 17:29 UTC, Lorenzo Delana
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Lorenzo Delana 2017-01-21 17:29:55 UTC
Created attachment 19433 [details]
repro working copy

attached a simple webapi selfhost solution, after run you can browse

http://localhost:5000/api/auth/now

and a response with current time.

but simply adding System.Net.Http reference cause the webapi work only for request while respond not work any more.

in the attachment working copy you can find two commits, the first with the working and the second with the non working.

A working_to_not_working.diff file is provided to show which changes done.
Comment 1 Marek Safar 2018-03-13 13:59:05 UTC
It works for me with the recent Mono versions