Bug 51685 - Hard crash with random NRE in 2.3.4.pre1 during VisualElement.Finalize
Summary: Hard crash with random NRE in 2.3.4.pre1 during VisualElement.Finalize
Status: RESOLVED DUPLICATE of bug 51503
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.4
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-01-21 12:50 UTC by Philipp Sumi
Modified: 2017-03-08 18:45 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 51503

Description Philipp Sumi 2017-01-21 12:50:15 UTC
Since having updated to XF 2.3.4-pre1 yesterday, I've had multiple hard crashes when triggering navigation from one page to the other (from different pages). All I'm seeing in the HockeyApp crash report are those NullReferenceExceptions:

android.runtime.JavaProxyThrowable: System.NullReferenceException: Object reference not set to an instance of an object
at Xamarin.Forms.VisualElement.Finalize()

I can reliably reproduce this if I just navigate back and forth often enough - eventually, it crashes after the button tap that triggers the navigation to the child page. When running in debug mode, the debugger doesn't give me anything. The app just dies.

This has showstopper quality - I hope the issue already sounds familiar to you.

Thanks,
Philipp
Comment 1 Philipp Sumi 2017-01-21 13:00:02 UTC
Just discovered this commit here:

https://github.com/xamarin/Xamarin.Forms/commit/a11e4c638b105c4d6466894c57a357c893996116


That description looks spot-on :)
Comment 2 Jimmy [MSFT] 2017-03-08 18:45:29 UTC

*** This bug has been marked as a duplicate of bug 51503 ***