This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 51553 - [UWP] Toolbar not shown for initial Detail page in MasterDetailPage
Summary: [UWP] Toolbar not shown for initial Detail page in MasterDetailPage
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows (show other bugs)
Version: 2.3.4
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-01-16 12:23 UTC by Serge
Modified: 2017-03-10 15:19 UTC (History)
7 users (show)

See Also:
Tags: ac
Is this bug a regression?: Yes
Last known good build: 2.3.3.180


Attachments
sample (51.45 KB, application/x-rar)
2017-01-16 12:23 UTC, Serge
Details

Description Serge 2017-01-16 12:23:16 UTC
Created attachment 19352 [details]
sample

Toolbar not shown for initial Detail page in MasterDetailPage. After changing Detail page toolbar works fine.

Issue appeared in 2.3.4.184-pre1, 2.3.3.180 works as expected.

Steps to reproduce:
1. run sample in attachement -> no toolbar visible
2. press "Button" to change Detail page -> toolbar appears
Comment 1 Jimmy 2017-03-06 20:22:14 UTC
See PR: https://github.com/xamarin/Xamarin.Forms/pull/744
Comment 2 Samantha Houts 2017-03-06 22:27:14 UTC
Should be fixed in 2.3.4-pre3. Thank you!
Comment 3 Serge 2017-03-10 09:12:51 UTC
I don't see PR 744 merged in 2.3.4-pre3. Just updated sample to 2.3.4-pre3, it's still broken.

Looks like you've uploaded something wrong to Nuget, because https://bugzilla.xamarin.com/show_bug.cgi?id=51642 is broken too.
Comment 4 Rui Marinho 2017-03-10 15:19:24 UTC
Sorry should be on 2.3.4-pre4

Note You need to log in before you can comment on or make changes to this bug.