Bug 51545 - [Crash] mono_threads_platform_set_priority: unknown policy 3
Summary: [Crash] mono_threads_platform_set_priority: unknown policy 3
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler (show other bugs)
Version: 7.1 (C9)
Hardware: PC Mac OS
: High major
Target Milestone: 7.1 (C9)
Assignee: Ludovic Henry
URL:
Depends on:
Blocks:
 
Reported: 2017-01-15 10:09 UTC by David Karlaš
Modified: 2017-02-16 17:08 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description David Karlaš 2017-01-15 10:09:37 UTC
This happens for me on Android emulator(didn't try real device) if I'm switching in and out of app a lot. It crashes with abort("mono_threads_platform_set_priority: unknown policy 3").

I'm assigning this to Henry since I think https://github.com/mono/mono/commit/fa41710fe0 caused this.

Since I think this is serious regression I'm setting target to C9 and High priority.
Comment 1 Ludovic Henry 2017-02-08 19:54:32 UTC
The PR for C9 is available at https://github.com/mono/mono/pull/4265 and the trello card at https://trello.com/c/3EVRl9iL/5-mono-fix-bug-51545

What are the next step to get it merged into C9?
Comment 2 Rodrigo Kumpera 2017-02-13 22:36:48 UTC
It was merged into mono, now it's up to the XA team to bump mono.

Jonp?
Comment 4 David Karlaš 2017-02-16 17:08:39 UTC
I'm verifying this is fixed, since now it just prints message but not crash application, which is exactly what fix is supposted to do: https://cloud.githubusercontent.com/assets/774791/23031600/e0a86fe0-f471-11e6-8e7c-a2090a9e04c2.png