Bug 51536 - Height of ViewCell and Height of ContextAction incorrectly measured
Summary: Height of ViewCell and Height of ContextAction incorrectly measured
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.3.4
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 51665 52746 53216 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-01-14 15:24 UTC by David Ortinau [MSFT]
Modified: 2017-03-14 16:33 UTC (History)
12 users (show)

Tags: ac
Is this bug a regression?: Yes
Last known good build: 2.3.3.180


Attachments
bad result (133.36 KB, image/jpeg)
2017-01-14 15:24 UTC, David Ortinau [MSFT]
Details
good result (159.73 KB, image/jpeg)
2017-01-14 15:25 UTC, David Ortinau [MSFT]
Details
sample list view page (6.74 KB, application/octet-stream)
2017-02-06 16:37 UTC, David Ortinau [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description David Ortinau [MSFT] 2017-01-14 15:24:58 UTC
Created attachment 19341 [details]
bad result

2.3.4.184-pre1

Reported by Bright Lee.
https://forums.xamarin.com/discussion/comment/245965#Comment_245965

"Height of ContextAction in ListView problem came back again. (iOS - XF2.3.4.184-pre1)

The problem was gone on XF2.3.3-SR1, and came back.

It ruins every UI for my ListView and fit to non-changable ContextAction height.

The height of my viewcell fit to ContextAction's button height, which means ContextAction's height does not follow ViewCell's height."
Comment 1 David Ortinau [MSFT] 2017-01-14 15:25:17 UTC
Created attachment 19342 [details]
good result
Comment 2 David Ortinau [MSFT] 2017-02-06 16:36:14 UTC
Confirmed good and bad results using the Forms Gallery ListView example. I'll upload the sample file.

Issue is not present in 2.3.3.180, and is present in 2.3.4.184-pre1 and the new pre2.
Comment 3 David Ortinau [MSFT] 2017-02-06 16:37:20 UTC
Created attachment 19729 [details]
sample list view page

Here's the sample demo page.
Comment 4 Bright Lee 2017-02-06 17:02:36 UTC
I faced this problem only on iPhone 5(iOS 10.2)

Thanks for your update.
I have a question.

What is the purpose of sample code for?
It's not a workaround, isn't it?
Comment 5 David Ortinau [MSFT] 2017-02-06 17:13:07 UTC
No, it's not a workout. It's a sample that shows can quickly be run to demonstrate the problem.

I'm seeing the same height problem in the iOS 7 simulator, 10.2.
Comment 6 Bright Lee 2017-02-06 17:28:47 UTC
Oh, I got it.
Comment 7 Matthias 2017-02-08 16:29:12 UTC
Same problem here with

OS: Windows 10 Pro
Microsoft Visual Studio Community 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01586

Installed Version: Community

Xamarin   4.2.2.11 (00fa5cc)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin Inspector Support   1.0.0.0 (1f3067d)
Adds support for inspecting Xamarin and WPF apps.

Xamarin.Android   7.0.2.42 (501e63c)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   10.3.1.8 (7beaef4)
Visual Studio extension to enable development for Xamarin.iOS.

Simulator: iPad 2 - iOS 9.0
Comment 8 Riccardo Marraghini 2017-02-10 17:09:18 UTC
Hello,

I'm also experiencing this bug on the app I'm working on.
X.F. 2.3.4 is required for the android side (has resolved SO MANY problems) but this bug is hitting hard on the iOS side.

By far I've encountered this bug on all lists with custom viewcells on these devices 

iPhone4s (9.3) (real and simulator)
iPhone5  (10.2) (real and simulator)
iPhone5s (10.2) (real and simulator)
iPhoneSE (10.2) (simulator, don't have access to a real one)

In my case the viewcells don't have context actions, but they are still "clipped" to the default size.

will this bug be fixed before 2.3.4 final?
Comment 9 David Ortinau [MSFT] 2017-02-18 14:30:52 UTC
We looked at the issue this week and were able to reproduce on iPhone SE. iPhone 7 appeared to be fine. I spoke directly with engineering about it, and think we're on the right track to resolving it. More to come.
Comment 10 Jimmy [MSFT] 2017-02-27 18:56:56 UTC
*** Bug 51665 has been marked as a duplicate of this bug. ***
Comment 11 Jimmy [MSFT] 2017-03-07 17:18:51 UTC
*** Bug 52746 has been marked as a duplicate of this bug. ***
Comment 12 Jimmy [MSFT] 2017-03-10 19:32:37 UTC
*** Bug 53216 has been marked as a duplicate of this bug. ***
Comment 13 Bright Lee 2017-03-11 14:21:45 UTC
Is this bug not fixed yet?
It's not on the release-note list of 2.3.4-pre4.

I think this bug is serious. :)
I can't use a newest forms because of this.
Comment 14 Samantha Houts [MSFT] 2017-03-13 18:43:50 UTC
https://github.com/xamarin/Xamarin.Forms/pull/787
Comment 15 Bright Lee 2017-03-13 18:52:49 UTC
Wow, looking the process is fantastic!

Thanks for the link.
Comment 16 Samantha Houts [MSFT] 2017-03-14 16:33:22 UTC
Should be fixed in 2.3.4-pre5. Thank you!