Bug 51519 - App crashing on Android tablets when using Xamarin 4.2
Summary: App crashing on Android tablets when using Xamarin 4.2
Status: RESOLVED DUPLICATE of bug 44907
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 4.2.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Cody Beyer (MSFT)
URL:
Depends on:
Blocks:
 
Reported: 2017-01-13 17:48 UTC by nimendez
Modified: 2017-10-04 19:34 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 44907

Description nimendez 2017-01-13 17:48:37 UTC
I am having an issue where my app crashes only on Android tablets. This usually happens during use, but occasionally it happens on start-up after deploying from VS.

I have attached 3 example stack traces (see post at https://forums.xamarin.com/discussion/86384/app-crashing-on-android-tablets-when-using-xamarin-4-2/). 1 and 2 were crashes that occurred during app use and 3 happened on start-up. The main commonality between them seems to be the part at the bottom:

01-12 11:04:09.596 E/mono-rt (16932): Attempting native Android stacktrace:
01-12 11:04:09.596 E/mono-rt (16932): 
01-12 11:04:09.600 E/mono-rt (16932): Could not unwind with libunwind.so: dlopen failed: library "/data/app/com.microsoft.dynamics.fs.mobile-1/lib/arm/libunwind.so" not found
01-12 11:04:09.600 E/mono-rt (16932): Could not unwind with libcorkscrew.so: dlopen failed: library "/data/app/com.microsoft.dynamics.fs.mobile-1/lib/arm/libcorkscrew.so" not found
01-12 11:04:09.600 E/mono-rt (16932): 
01-12 11:04:09.600 E/mono-rt (16932): No options left to get a native stacktrace :-(
01-12 11:04:09.600 E/mono-rt (16932): 
01-12 11:04:09.600 E/mono-rt (16932): =================================================================
01-12 11:04:09.600 E/mono-rt (16932): Got a SIGSEGV while executing native code. This usually indicates
01-12 11:04:09.600 E/mono-rt (16932): a fatal error in the mono runtime or one of the native libraries 
01-12 11:04:09.600 E/mono-rt (16932): used by your application.
01-12 11:04:09.600 E/mono-rt (16932): =================================================================
01-12 11:04:09.600 E/mono-rt (16932): 
01-12 11:04:09.600 F/libc (16932): Fatal signal 11 (SIGSEGV), code 1, fault addr 0x8 in tid 16932 (amics.fs.mobile)

If I downgrade my Xamarin version to 4.1.2.18, this problem goes away. If I move to version 4.2.0.680, the crash again happens.

As mentioned, this is only affecting our Android tablet, a Nexus 9 running Android 7.0 with the security patch from 11/5/16. We cannot repro the problem on Android phones running either Android 6 or 7.

Our app is located at this repo: https://dynamicscrm.visualstudio.com/FPS/_git/Mobile
If an FTE from Microsoft wants to investigate this crash, they can reach out to us to grant permissions and provide specific repro steps.
Comment 1 Al Clark [MSFT] 2017-08-23 23:48:18 UTC
Please grant me permission so I can take a look for you :)
Comment 2 Jon Douglas [MSFT] 2017-10-04 17:08:00 UTC
I believe this issue might be a duplicate of this private Android issue: 
https://bugzilla.xamarin.com/show_bug.cgi?id=46482#c2

https://bugzilla.xamarin.com/show_bug.cgi?id=46482#c4 which has some comments regarding the hardware being faulty in other runtimes:

https://github.com/golang/go/issues/19809#issuecomment-290804472

This seems oddly closely related to the nexus 9 issue.

I've added you on the CC list to the private bug I've marked this as a duplicate of so you can view them.

*** This bug has been marked as a duplicate of bug 44907 ***