Bug 51475 - Accessibility:MAS 20: "Tooltip" control is not defined programatically
Summary: Accessibility:MAS 20: "Tooltip" control is not defined programatically
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-12 09:41 UTC by v-sukals@microsoft.com
Modified: 2017-10-04 11:42 UTC (History)
4 users (show)

Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
Inspect Log (82.05 KB, image/png)
2017-01-12 09:41 UTC, v-sukals@microsoft.com
Details
Tooltip does not exist in the window (81.99 KB, image/png)
2017-09-29 11:28 UTC, v-sukals@microsoft.com
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description v-sukals@microsoft.com 2017-01-12 09:41:05 UTC
Created attachment 19300 [details]
Inspect Log

Repro Steps:
1. Launch Visual Studio RC 2017
2. Open File+New Project+Select "Crossplatform" from the Left Pane
3. Select "Cross Platform App"."New Crossplatform" window opens
4. Select "Blank App" 
5. Press Ok button
6. Solution Window Appears at Right pane
7. Tab to the "Solution Explorer"
8. Tab to the App Name(For Ex: App2.Droid) and press Shift+F10
9. Select "Properties" option from the list 10. press Enter Key. Properties window appears 
10. Select "Android options" from Left pane
11. Launch Inspect tool
12. Find "package pane" from left inspect  tree
13. Select "pane" element from the tree(Refer to the screenshot "Tooltip-inspect")
14.Observe "Name","LocalizedControltype",
   "Help text" properties in inspect tool

Actual Behavior:
"Name" and "Help text" properties are empty
"LocalizedControlType" is defined as pane

Expected Behavior:
1. Name property should not be empty. 
   Name property should be defined according the relevant element's information.
2. The tooltip appears with mouse hover should be updated in "Help Text"
3. "Localizedcontroltype" should be "tooltip"


User impact:
Narrator Focus is not moving to the Tool tip region(?) because it is not defined programatically.
User reliable on screen reader cannot access the tool tip information
Comment 1 Nick Sadovyi 2017-09-11 08:08:25 UTC
Fixed (master)

Author: Nick
Commit: a35622a663fb8b5f787d1ff2ee13484b02bba3c0 (xamarin/XamarinVS)
Comment 2 v-sukals@microsoft.com 2017-09-19 11:57:45 UTC
Environment (master) is not available to verify the issue
Comment 3 v-sukals@microsoft.com 2017-09-29 11:28:31 UTC
Created attachment 25026 [details]
Tooltip does not exist in the window
Comment 4 v-sukals@microsoft.com 2017-10-04 11:42:29 UTC
Tooltip does not exist in the build. UI element has been removed. Hence closing the bug.

Note: Please find the attached screenshot for more info.
[Screenshot: Tooltip does not exist in the window]