Bug 51474 - Usability:CAPS+Right/Left arrow Navigation is not sequential in overall xamarin application
Summary: Usability:CAPS+Right/Left arrow Navigation is not sequential in overall xamar...
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-12 09:37 UTC by v-sukals@microsoft.com
Modified: 2017-10-07 12:26 UTC (History)
4 users (show)

See Also:
Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
Inspect and narrator buddy logs (311.51 KB, application/x-zip-compressed)
2017-01-12 09:37 UTC, v-sukals@microsoft.com
Details
Issue is fixed- Inspect and Narrator buddy Logs (455.61 KB, application/x-zip-compressed)
2017-10-07 12:21 UTC, v-sukals@microsoft.com
Details

Description v-sukals@microsoft.com 2017-01-12 09:37:08 UTC
Repro Steps:
Scenario 1:
1. Launch Visual Studio RC 2017
2. Open File+New Project+Select "Crossplatform" from the Left Pane
3. Select "Cross Platform App"."New Crossplatform" window opens
4. Select "Blank App" 
5. Press Ok button
6. Open tools-->Option-->Xamarin-->Android Settings
7. Using Tab navigate to Settings pane. 
8. Read all UI elements using CAPS+Right arrow key and CAPS+Left arrow key(Equivalent to Tab/Shift Tab navigation with narrator keys)

Scenario2:
1. Launch Visual Studio RC 2017
2. Open File+New Project+Select "Crossplatform" from the Left Pane
3. Select "Cross Platform App"."New Crossplatform" window opens
4. Select "Blank App" 
5. Press Ok button
6. Solution Window Appears at Right pane
7. Tab to the "Solution Explorer"
8. Tab to the App Name(For Ex: App2.Droid) and press Shift+F10
9. Select "Properties" option from the list 
10. press Enter Key. Application Properties window appears 
11. Tab to "Assembly Name" edit box. 
12. Using CAPS+Right arrow key navigate through UI elements in "Application" region


Actual Behavior:
Scenario 1:
Focus order is not sequential with Narrator keys
Ex: When Focus is on "Java Development Kit Location" heading caps+Right arrow navigation is 

change link next to "Android NDK Location" -->C:Program Data-->Android NDK Location-->Emulator /Device Debugging..

Narrator focus is moving randomly from one item to other

Scenario 2:
Narrator Focus moved from edit box to list of the tab items in left tree-->Next tab in the window

Note:
Same issue is observe in all windows of Xamarin application

Expected Behavior:
Narrator Navigation should be in sequential order


User impact:
User reliable on Narrator will user CAPS+Right/Left arrow keys to navigate all the UI elements,headings in window. If Narrator navigation is not sequential Screen reader user get incorrect results
Comment 1 v-sukals@microsoft.com 2017-01-12 09:37:37 UTC
Created attachment 19299 [details]
Inspect and narrator buddy logs
Comment 2 Nick Sadovyi 2017-09-05 13:45:30 UTC
Fixed (master)

Author: Nick
Commit: 86a0c010c77a54bb64b7b4183bf36eb6cc787b9b (xamarin/XamarinVS)
Comment 3 v-sukals@microsoft.com 2017-10-07 12:21:14 UTC
Created attachment 25198 [details]
Issue is fixed- Inspect and Narrator buddy Logs
Comment 4 v-sukals@microsoft.com 2017-10-07 12:26:13 UTC
Verified the issue and the issue is fixed -  Focus order sequential with Narrator keys in "Android Settings-Option" pop-up window, hence closing the bug.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27006.1.d15rel]
Xamarin Version: 4.8.0.559(dbde9cdd3)

Note: Please find the attachment for more info.
[Attachment: Issue is fixed-Inspect and Narrator buddy Logs]

Note You need to log in before you can comment on or make changes to this bug.