Bug 51470 - Usability:Narrator is not reading "Next" button
Summary: Usability:Narrator is not reading "Next" button
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-12 09:28 UTC by v-sukals@microsoft.com
Modified: 2017-10-04 10:34 UTC (History)
4 users (show)

See Also:
Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
Inspect log (104.70 KB, image/png)
2017-01-12 09:28 UTC, v-sukals@microsoft.com
Details
Narrator buddy log (117.82 KB, image/png)
2017-01-12 09:28 UTC, v-sukals@microsoft.com
Details
Issue is fixed - Narrator is reading Next button (150.77 KB, image/png)
2017-10-04 10:31 UTC, v-sukals@microsoft.com
Details

Description v-sukals@microsoft.com 2017-01-12 09:28:07 UTC
Created attachment 19294 [details]
Inspect log

Repro Steps:
1. Launch Visual Studio RC 2017
2. Open File+New Project+Select "Crossplatform" from the Left Pane
3. Select "Cross Platform App"."New Crossplatform" window opens
4. Select "Blank App" 
5. Press Ok button
6. Open Tools-->Options
7. "Options" window opens. Navigate to "Xamarin" and expand. 
8. Select "iOS Settings"
9. Change Narrator mode to "Item Mode" using CAPS+up/down arrow keys
10. Tab to "Find xamarin Mac agent" button and press CAPS+Enter Key
11. "Xamarin Mac Agent Instructions" window opens. 
12. Tab to "next button" and observe Narrator announcement

Actual Behavior:
Narrator is not reading the "Next" button.
When Focus is on Next button Narrator is not reading anything.
Same issue is observed for "Close" button in "Xamarin mac Agent Window"

Note: In Inspect "Name" property Is defined correctly. In Narrator buddy log also showing narrator read the next button. But actually it is not reading

Expected Behavior:
Narrator should read "Next" button while navigating using tab key


User impact:
If narrator is not reading anything, it creates ambiguty to screen reader users
Comment 1 v-sukals@microsoft.com 2017-01-12 09:28:24 UTC
Created attachment 19295 [details]
Narrator buddy log
Comment 2 Nick Sadovyi 2017-09-12 07:51:37 UTC
Fixed (master)

Author: Nick
Commit: 4411d7accb1affca3e0dc48cc82330bb89e77a40 (xamarin/XamarinVS)
Comment 3 v-sukals@microsoft.com 2017-10-04 10:31:03 UTC
Created attachment 25087 [details]
Issue is fixed - Narrator is reading Next button
Comment 4 v-sukals@microsoft.com 2017-10-04 10:34:44 UTC
Verified the issue and the issue is fixed - Narrator is reading "Next" button, hence closing the bug.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27002.0.d15rel]
Xamarin Version: 4.8.0.315(50450332e)

Note: Please find the attached screenshot for more info.
[Screenshot: Issue is fixed - Narrator is reading Next button]

Note You need to log in before you can comment on or make changes to this bug.