Bug 51461 - Accessibility:MAS40B:Name property is empty for "User Name" and "Password" fields in "Connect to Mac Window"
Summary: Accessibility:MAS40B:Name property is empty for "User Name" and "Password" fi...
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-12 07:04 UTC by v-sukals@microsoft.com
Modified: 2017-10-07 13:57 UTC (History)
4 users (show)

Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
Inspect Log (91.48 KB, image/png)
2017-01-12 07:04 UTC, v-sukals@microsoft.com
Details
Inspect-Issue is fixed-Password edit box (155.89 KB, image/png)
2017-10-07 13:55 UTC, v-sukals@microsoft.com
Details
Inspect-Issue is fixed-Username edit box (154.34 KB, image/png)
2017-10-07 13:55 UTC, v-sukals@microsoft.com
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description v-sukals@microsoft.com 2017-01-12 07:04:25 UTC
Created attachment 19281 [details]
Inspect Log

Repro Steps:
1. Launch Visual Studio RC 2017
2. Open Tools-->Options-->Xamarin-->iOS Settings -->Find Xamarin Agent
3."Xamarin Mac Agent" window opens(Make sure that a mac is connected)
4. Launch Inspect tool
5. Using Tab navigate to the Mac Name which is connected.
6. Right click for context menu. Select Connect option
7. "Connect to Mac window" opens
8. Launch inspect tool
9. Observe Name property for "Username" and "Password" fields in inspect"

Actual Behavior:
Name property is empty for "user Name" and "Password" fields

Expected Behavior:
Name property should be defined as "User Name", "Password"


User impact:
Screen Reader reads as "Editing" when focus is on "user Name" and "Password Fields". User rely on screen reader cannot identify name of the fields
Comment 1 Nick Sadovyi 2017-09-12 07:51:52 UTC
Fixed (master)

Author: Nick
Commit: 4411d7accb1affca3e0dc48cc82330bb89e77a40 (xamarin/XamarinVS)
Comment 2 v-sukals@microsoft.com 2017-09-19 12:02:16 UTC
Xamarin version (master) is not available to verify the issue.
Comment 3 v-sukals@microsoft.com 2017-10-07 13:55:02 UTC
Created attachment 25200 [details]
Inspect-Issue is fixed-Password edit  box
Comment 4 v-sukals@microsoft.com 2017-10-07 13:55:42 UTC
Created attachment 25201 [details]
Inspect-Issue is fixed-Username edit  box
Comment 5 v-sukals@microsoft.com 2017-10-07 13:57:13 UTC
Verified the issue and the issue is fixed - Name property is appropriate for "Username" and "Password" edit box, hence closing the bug.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27006.1.d15rel]
Xamarin Version: 4.8.0.559(dbde9cdd3)

Note: Please find the latest attachment for more info.