Bug 51457 - Accessibility:MAS40: Buildcomments and Errors are not defined properly in inspect
Summary: Accessibility:MAS40: Buildcomments and Errors are not defined properly in ins...
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-12 06:58 UTC by v-sukals@microsoft.com
Modified: 2017-10-07 12:13 UTC (History)
4 users (show)

See Also:
Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
Inspect Log (111.82 KB, image/png)
2017-01-12 06:58 UTC, v-sukals@microsoft.com
Details
Inspect-Issue is fixed-Build comments are defined properly in inspect (124.42 KB, image/png)
2017-10-07 12:04 UTC, v-sukals@microsoft.com
Details
Inspect-Issue is fixed-errors are defined properly in inspect (119.26 KB, image/png)
2017-10-07 12:04 UTC, v-sukals@microsoft.com
Details

Description v-sukals@microsoft.com 2017-01-12 06:58:11 UTC
Created attachment 19275 [details]
Inspect Log

Repro Steps:
1. Launch Visual Studio RC 2017
2. Open File+New Project+Select "Crossplatform" from the Left Pane
3. Select "Cross Platform App"."New Crossplatform" window opens
4. Select "Blank App" 
5. Press Ok button
6. Solution Window Appears at Right pane
7. Tab to the "Solution Explorer"
8. Tab to the iOS App Name(Of Ex: App2.iOS)
9. Press Shift+F10 .Select "Archives" option from context menu
10. "Archive Manger" opens.
11. In Inspect Identify "Build Comments" and "Errors" region in inspect left tree(Refer to Screen shot "BuildComments-Errors-Inspect")

Actual Behavior:
"Build Comments" is defined as 
custom-->button-->build comments text-->custom-->edit-->text

"Errors" is defined as 
custom-->button-->errors text-->listview--> xamarin.ide.errors list item-->failed to create(error message)-->text-->text

Expected Behavior:
"Build Comments" should be defined as 

custom-->build comments button-->comments list item

"Errors" should be defined as 
Custom-->Errors button-->Failed to create("error message" list item)


User impact:
While navigation using CAPS+Right arrow key(Narrator navigation),
The Focus will go to "button" followed by text 
User Rely on screen reader cannot identify "Build comments" is a button
Comment 1 Nick Sadovyi 2017-09-05 06:47:26 UTC
Fixed (master)

Author: Nick
Commit: 11935c5d7de5a6f57e324521d1ab6f6eaf71d5e7 (xamarin/XamarinVS)
Comment 2 v-sukals@microsoft.com 2017-09-13 12:17:26 UTC
Xamarin version (master) is not available to verify the issue
Comment 3 v-sukals@microsoft.com 2017-10-07 12:04:20 UTC
Created attachment 25196 [details]
Inspect-Issue is fixed-Build comments are defined properly in inspect
Comment 4 v-sukals@microsoft.com 2017-10-07 12:04:51 UTC
Created attachment 25197 [details]
Inspect-Issue is fixed-errors are defined properly in inspect
Comment 5 v-sukals@microsoft.com 2017-10-07 12:13:10 UTC
Verified the issue and the issue is fixed - Build comments and Errors are defined properly in inspect, hence closing the bug.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27006.1.d15rel]
Xamarin Version: 4.8.0.559(dbde9cdd3)

Note: Please find the latest attachment for more info.

Note You need to log in before you can comment on or make changes to this bug.