Bug 51455 - Accessibility: MAS42A: 'Edit Pre-build' and 'Edit Post-build' buttons are not in compliance with any of the High Contrast themes.
Summary: Accessibility: MAS42A: 'Edit Pre-build' and 'Edit Post-build' buttons are not...
Status: CLOSED UPSTREAM
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-12 06:48 UTC by v-sukals@microsoft.com
Modified: 2018-05-02 14:23 UTC (History)
3 users (show)

Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
HC_visualstudio_xamarin_Editprebuild (58.45 KB, image/jpeg)
2017-01-12 06:48 UTC, v-sukals@microsoft.com
Details
HCB-Issue is not fixed-Edit Pre-build and Edit Post-build buttons (85.51 KB, image/png)
2017-10-07 11:12 UTC, v-sukals@microsoft.com
Details
HCW-Issue is not fixed-Edit Pre-build and Edit Post-build buttons (85.15 KB, image/png)
2017-10-07 11:13 UTC, v-sukals@microsoft.com
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED UPSTREAM

Description v-sukals@microsoft.com 2017-01-12 06:48:00 UTC
Created attachment 19272 [details]
HC_visualstudio_xamarin_Editprebuild

Steps:-
1. Launch the application
2. Go to File > New > Project
3. Select Cross-Platform > Cross Platform App
4. Select Blank App and Accept
5. Navigate to Project name (App*.Droid) in Solution Explorer and select properties from context menu
6. Click on Android Options in LHS pane and press Tab key to navigate to 'Edit Pre-build' and 'Edit Post-build' buttons
7. Observe the button theme(button gets highlighted but text colour doesn't change accordingly)


Expected Result:-
As soon as the button is focused and highlighted, text colour should change as per the high contrast theme

Actual Result:-
In High Contrast Black theme, when the button is focused, button is highlighted but text colour remains white
And, In High Contrast White theme, both the  buttons get highlighted but text colour remains black

Platform/browser:-
OS: Windows RS1
Visual Studio Version: Visual Studio Enterprise 2017RC(15.0.25928.0)
Xamarin Version: 4.3.0.241
Comment 1 Jose Gallardo 2017-06-06 20:11:21 UTC
We're including new Properties, Manifests and Entitlements editor on 15.3 (d15-3).
However, in 4.6.0.224 (d15-3) we're still failing on HC black theme for all the new Property pages (not for the manifest or entitlements editors).

I'm leaving this bug as confirmed until we fix it.
Comment 2 xamarin-release-manager 2017-08-24 20:17:47 UTC
Fixed in version 4.8.0.248 (master)

Author: josegallardo
Commit: 8405edd871db5285d82128c81c3dbf8ca30a61a6 (xamarin/XamarinVS)
Comment 3 v-sukals@microsoft.com 2017-09-13 12:10:50 UTC
Xamarin Version 4.8.0.248 (master) is not available to verify the issue.
Comment 4 v-sukals@microsoft.com 2017-10-07 11:12:54 UTC
Created attachment 25194 [details]
HCB-Issue is not fixed-Edit Pre-build and Edit Post-build buttons
Comment 5 v-sukals@microsoft.com 2017-10-07 11:13:13 UTC
Created attachment 25195 [details]
HCW-Issue is not fixed-Edit Pre-build and Edit Post-build buttons
Comment 6 v-sukals@microsoft.com 2017-10-07 11:15:55 UTC
Verified the issue and the issue is not fixed, hence reactivating the bug.
Observation:
1. When the button get focused button's text is displayed in white color. It should display in black color as per high contrast black standards.
2. When the button get focused button's text is displayed in black color. It should display in white color as per high contrast white standards.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27006.1.d15rel]
Xamarin Version: 4.8.0.559(dbde9cdd3)

Note: Please find the attachment for more info.
Attachments:
1.HCB-Issue is not fixed-Edit Pre-build and Edit Post-build buttons
2.HCW-Issue is not fixed-Edit Pre-build and Edit Post-build buttons
Comment 7 Adrian Murphy 2018-02-12 20:22:37 UTC
Per Jose, he believes this is an issue with the Windows VS IDE itself, not the Xamarin VS tools. Consulted with Salieu Njie, and he said to make a vSTS work item for the VS IDE team to address. As such, created VSTS work item 566518 (https://devdiv.visualstudio.com/DevDiv/_workitems/edit/566518) for Windows VS IDE team to address.
Comment 8 v-sukals@microsoft.com 2018-05-02 14:23:51 UTC
https://microsoft-my.sharepoint.com/:i:/p/v-snena/ESLq8PEZdTZGhxkbpTWY5-wBJ_5keLyOdnA_aQ2KnfEM6A?e=3gswiD

https://microsoft-my.sharepoint.com/:i:/p/v-snena/EbqO6LsE6aZFrwRBSCESQWoBNCtqRW1x0MI9gNoH-YwulA?e=5bED6X

The attachment is shared in the above mentioned path. Please refer the screenshot. 
Verified the issue and the issue is fixed. Hence closing the bug.

Verified Windows Version:
Windows 10 Enterprise
OS Version 1709 (OS Build 16299.192)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15.7
Version 15.7.0 Preview 5.0[27625.0.d15.7]
Xamarin Version: 4.10.0.440(943b34d9d)