Bug 51454 - Accessibility:MAS40:"Current Solution" and "All Archives" buttons are not defined properly in inspect
Summary: Accessibility:MAS40:"Current Solution" and "All Archives" buttons are not def...
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-12 06:43 UTC by v-sukals@microsoft.com
Modified: 2017-10-07 11:00 UTC (History)
3 users (show)

See Also:
Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
Inspect Log (102.70 KB, image/png)
2017-01-12 06:43 UTC, v-sukals@microsoft.com
Details
Narrator buddy log (56.71 KB, image/png)
2017-01-12 06:43 UTC, v-sukals@microsoft.com
Details
Issue is fixed- Inspect and Narrator buddy Logs (316.20 KB, application/x-zip-compressed)
2017-10-07 10:56 UTC, v-sukals@microsoft.com
Details

Description v-sukals@microsoft.com 2017-01-12 06:43:06 UTC
Created attachment 19270 [details]
Inspect Log

Repro Steps:
1. Launch Visual Studio RC 2017
2. Open File+New Project+Select "Crossplatform" from the Left Pane
3. Select "Cross Platform App"."New Crossplatform" window opens
4. Select "Blank App" 
5. Press Ok button
6. Solution Window Appears at Right pane
7. Tab to the "Solution Explorer"
8. Tab to the iOS App Name(Of Ex: App2.iOS)
9. Press Shift+F10 .Select "Archives" option from context menu
10. "Archive Manger" opens
12. Launch Inspect tool
13. Using tab key navigate to the left navigation pane. 
14. In inspect tool identify "Current Solution" and "All Archives" buttons(Refer to Screenshot "CurrentSolution-AllArchives-Inspect"

Actual Behavior:
"Current Sollution" button is defined in below sequence 
custom-->button-->Current Solution text-->list view

"All Archives" defined as 
custom-->button-->All archives text-->List View

Expected Behavior:
"Current solution" should be defined as 
"Custom-->CurrentSolution button-->List View


"All archives" should be defined as 
Custom-->All archives button-->List View


User impact:
While navigation using CAPS+Right arrow key(Narrator navigation),
The Focus will go to "button" followed by text. 
User Rely on screen reader cannot identify "Current Solution" is a button
Comment 1 v-sukals@microsoft.com 2017-01-12 06:43:23 UTC
Created attachment 19271 [details]
Narrator buddy log
Comment 2 xamarin-release-manager 2017-09-08 14:16:17 UTC
Fixed in version 4.8.0.373 (master)

Author: nickolay-sadovoy
Commit: d1aa8800ec8e1b99a6be47e9713e8f5df3a1c049 (xamarin/XamarinVS)
Comment 3 v-sukals@microsoft.com 2017-09-19 12:09:06 UTC
Xamarin version 4.8.0.373 (master) is not available to verify the issue
Comment 4 v-sukals@microsoft.com 2017-10-07 10:56:03 UTC
Created attachment 25193 [details]
Issue is fixed- Inspect and Narrator buddy Logs
Comment 5 v-sukals@microsoft.com 2017-10-07 11:00:58 UTC
Verified the issue and the issue is fixed - "Current Solution" and "All archives" buttons are defined properly in inspect, hence closing the bug.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27006.1.d15rel]
Xamarin Version: 4.8.0.559(dbde9cdd3)

Note: Please find the attachment for more info.
[Attachment: Issue is fixed-Inspect and Narrator buddy Logs]

Note You need to log in before you can comment on or make changes to this bug.