Bug 51453 - Accessibility:MAS40B:Name of the appllication is not defined properly in Archive Manager
Summary: Accessibility:MAS40B:Name of the appllication is not defined properly in Arch...
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-12 06:30 UTC by v-sukals@microsoft.com
Modified: 2018-05-02 14:19 UTC (History)
4 users (show)

Tags: a11ymas,wipro, A11y15.8ExceptionRequested
Is this bug a regression?: ---
Last known good build:


Attachments
Inspect Log (94.06 KB, image/png)
2017-01-12 06:31 UTC, v-sukals@microsoft.com
Details
Narrator buddy log (64.87 KB, image/png)
2017-01-12 06:31 UTC, v-sukals@microsoft.com
Details
Inspect Log-Issue is not fixed (114.65 KB, image/png)
2017-10-07 10:41 UTC, v-sukals@microsoft.com
Details
Narrator buddy Log-Issue is not fixed (84.12 KB, image/png)
2017-10-07 10:42 UTC, v-sukals@microsoft.com
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description v-sukals@microsoft.com 2017-01-12 06:30:44 UTC
Repro Steps:
1. Launch Visual Studio RC 2017
2. Open File+New Project+Select "Crossplatform" from the Left Pane
3. Select "Cross Platform App"."New Crossplatform" window opens
4. Select "Blank App" 
5. Press Ok button
6. Solution Window Appears at Right pane
7. Tab to the "Solution Explorer"
8. Tab to the iOS App Name(Of Ex: App2.iOS)
9. Press Shift+F10 .Select "Archives" option from context menu
10. "Archive Manger" opens
12. Launch Inspect tool
13. Using tab navigate to the Application name in Right Navigation Pane

Actual Behavior:
1. Name property is defined as "Xamarin.visualstudio.publishing.Presentation.ViewModels.ArchiveModel 1 of 1 selected"
2. Created date, Version and error text are not part of Name property

Expected Behavior:
1. Name property should be defined as "App2.iOS"(Application Name)
2. Created date, version should be included in Name property
3. Error/Info text "The archiving Process has failed. Please see the Errors section for more details" should be defined in Help Text/Full Description


User impact:
User Rely on screen reader cannot identify the name property and application details of Application
Comment 1 v-sukals@microsoft.com 2017-01-12 06:31:10 UTC
Created attachment 19268 [details]
Inspect Log
Comment 2 v-sukals@microsoft.com 2017-01-12 06:31:30 UTC
Created attachment 19269 [details]
Narrator buddy log
Comment 3 Nick Sadovyi 2017-09-11 08:05:20 UTC
Fixed in version 4.8.0.373 (master)

Author: nickolay-sadovoy
Commit: 1be1167fbd9c1c5606aee08e1445c00558ea5a3f (xamarin/XamarinVS)
Comment 4 v-sukals@microsoft.com 2017-09-19 12:11:20 UTC
Xamarin version 4.8.0.373 (master) is not available to verify the issue.
Comment 5 v-sukals@microsoft.com 2017-10-07 10:41:52 UTC
Created attachment 25191 [details]
Inspect Log-Issue is not fixed
Comment 6 v-sukals@microsoft.com 2017-10-07 10:42:13 UTC
Created attachment 25192 [details]
Narrator buddy Log-Issue is not fixed
Comment 7 v-sukals@microsoft.com 2017-10-07 10:48:34 UTC
Verified the issue and the issue is partially fixed, hence reactivating the bug.
Observation:
1. Name is defined properly for archive file.
2. Creation Date and Version are defined in help text but the error message "The archiving Process has failed. Please see the Errors section for more details" is not defined in Help text or Full description.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27006.1.d15rel]
Xamarin Version: 4.8.0.559(dbde9cdd3)

Note: Please find the attachment for more info.
[Attachment: Inspect Log-Issue is not fixed and
Narrator buddy Log-Issue is not fixed]
Comment 8 Jose Gallardo 2018-04-09 13:29:20 UTC
Fixed on PRs
master: https://github.com/xamarin/XamarinVS/pull/9056
d15-7: https://github.com/xamarin/XamarinVS/pull/9055
Comment 9 v-sukals@microsoft.com 2018-05-02 14:19:36 UTC
https://microsoft-my.sharepoint.com/:i:/p/v-snena/ETE-SPw8NDVKrxjDIwFroJEBG1AFjDciKmSdFN22STL9Og?e=7cj5jk

The attachment is shared in the above mentioned path. Please refer the screenshot. 
Verified the issue and the issue is fixed. Hence closing the bug.

Verified Windows Version:
Windows 10 Enterprise
OS Version 1709 (OS Build 16299.192)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15.7
Version 15.7.0 Preview 5.0[27625.0.d15.7]
Xamarin Version: 4.10.0.440(943b34d9d)