Bug 51451 - Accessibility:MAS 40B: Name property is incorrect for "Application Name" in Archive Manager
Summary: Accessibility:MAS 40B: Name property is incorrect for "Application Name" in A...
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-12 06:16 UTC by v-sukals@microsoft.com
Modified: 2017-10-07 10:13 UTC (History)
4 users (show)

Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
Inspect log (56.31 KB, image/png)
2017-01-12 06:16 UTC, v-sukals@microsoft.com
Details
Narrator buddy log (60.20 KB, image/png)
2017-01-12 06:16 UTC, v-sukals@microsoft.com
Details
Inspect-Issue is fixed-Application name (119.91 KB, image/png)
2017-10-07 10:10 UTC, v-sukals@microsoft.com
Details
Narrator buddy-Issue is fixed-Application name (86.97 KB, image/png)
2017-10-07 10:10 UTC, v-sukals@microsoft.com
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description v-sukals@microsoft.com 2017-01-12 06:16:10 UTC
Repro Steps:
1. Launch Visual Studio RC 2017
2. Open File+New Project+Select "Crossplatform" from the Left Pane
3. Select "Cross Platform App"."New Crossplatform" window opens
4. Select "Blank App" 
5. Press Ok button
6. Solution Window Appears at Right pane
7. Tab to the "Solution Explorer"
8. Tab to the iOS App Name(Of Ex: App2.iOS)
9. Press Shift+F10 .Select "Archives" option from context menu
10. "Archive Manger" opens
12. Launch Inspect tool
13. Using tab navigate to the Application name below to "Current Solution" 
14. Observe Name property in inspect tool

Actual Behavior:
Name property Is defined as "Xamarin.visualstudio.publishing.Presentation.ViewModels.ArchiveModel 1 of 1 selected"

Expected Behavior:
Nam property should be defined as  
"App2.iOS"(Application name)


User impact:
Screen reader reads inappropriate name defined in inspect which creates ambiguity to visually imparied users
Comment 1 v-sukals@microsoft.com 2017-01-12 06:16:24 UTC
Created attachment 19265 [details]
Inspect log
Comment 2 v-sukals@microsoft.com 2017-01-12 06:16:44 UTC
Created attachment 19266 [details]
Narrator buddy log
Comment 3 Nick Sadovyi 2017-09-11 08:05:29 UTC
Fixed in version 4.8.0.373 (master)

Author: nickolay-sadovoy
Commit: 1be1167fbd9c1c5606aee08e1445c00558ea5a3f (xamarin/XamarinVS)
Comment 4 v-sukals@microsoft.com 2017-09-19 12:12:27 UTC
Xamarin version 4.8.0.373 (master) is not available to verify the issue
Comment 5 v-sukals@microsoft.com 2017-10-07 10:10:21 UTC
Created attachment 25188 [details]
Inspect-Issue is fixed-Application name
Comment 6 v-sukals@microsoft.com 2017-10-07 10:10:46 UTC
Created attachment 25189 [details]
Narrator buddy-Issue is fixed-Application name
Comment 7 v-sukals@microsoft.com 2017-10-07 10:13:03 UTC
Verified the issue and the issue is fixed - Name is defined properly for the Application name under Current solution , hence closing the bug.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27006.1.d15rel]
Xamarin Version: 4.8.0.559(dbde9cdd3)

Note: Please find the latest attachment for more info.