Bug 51449 - Accessibility:MAS40B:Name property is empty for search button and search edit box in "Archive Manager" window
Summary: Accessibility:MAS40B:Name property is empty for search button and search edit...
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-12 06:11 UTC by v-sukals@microsoft.com
Modified: 2017-10-07 07:48 UTC (History)
4 users (show)

Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
Inspect log (79.50 KB, image/png)
2017-01-12 06:11 UTC, v-sukals@microsoft.com
Details
Narrator buddy log (10.98 KB, image/png)
2017-01-12 06:12 UTC, v-sukals@microsoft.com
Details
Issue is fixed-Inspect and Narrator buddy Logs (296.89 KB, application/x-zip-compressed)
2017-10-07 07:43 UTC, v-sukals@microsoft.com
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description v-sukals@microsoft.com 2017-01-12 06:11:56 UTC
Created attachment 19262 [details]
Inspect log

Repro Steps:
1. Launch Visual Studio RC 2017
2. Open File+New Project+Select "Crossplatform" from the Left Pane
3. Select "Cross Platform App"."New Crossplatform" window opens
4. Select "Blank App" 
5. Press Ok button
6. Solution Window Appears at Right pane
7. Tab to the "Solution Explorer"
8. Tab to the iOS App Name(Of Ex: App2.iOS)
9. Press Shift+F10 .Select "Archives" option from context menu
10. "Archive Manger" opens
11. using tab navigate to "Search Edit box" and Search button in left pane
12. launch inspect .
13. Observe Name property for Search edit box and search button in inspect

Actual Behavior:
Name property is empty for search edit box and search button

Expected Behavior:
Name property should be defined for search edit box and search button


User impact:
Screen reader reads only control type with out reading the name of the control. Loss of information to visually impaired user
Comment 1 v-sukals@microsoft.com 2017-01-12 06:12:31 UTC
Created attachment 19264 [details]
Narrator buddy log
Comment 2 Nick Sadovyi 2017-09-11 08:05:41 UTC
Fixed in version 4.8.0.373 (master)

Author: nickolay-sadovoy
Commit: 1be1167fbd9c1c5606aee08e1445c00558ea5a3f (xamarin/XamarinVS)
Comment 3 v-sukals@microsoft.com 2017-09-19 12:13:31 UTC
Xamarin version 4.8.0.373 (master) is not available to verify the issue.
Comment 4 v-sukals@microsoft.com 2017-10-07 07:43:07 UTC
Created attachment 25184 [details]
Issue is fixed-Inspect and Narrator buddy Logs
Comment 5 v-sukals@microsoft.com 2017-10-07 07:48:55 UTC
Verified the issue and the issue is fixed - Name property is appropriate for "Search" edit box and "Search" button, hence closing the bug.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27006.1.d15rel]
Xamarin Version: 4.8.0.559(dbde9cdd3)

Note: Please find the attachment for more info.
[Attachment: Issue is fixed-Inspect and Narrator buddy Logs]