Bug 51442 - Accessibility:MAS 40B:"Name" property is incomprehensible for "Environment Variables" table
Summary: Accessibility:MAS 40B:"Name" property is incomprehensible for "Environment Va...
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-12 05:26 UTC by v-sukals@microsoft.com
Modified: 2017-10-07 10:06 UTC (History)
3 users (show)

Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
Inspect log (77.99 KB, image/png)
2017-01-12 05:26 UTC, v-sukals@microsoft.com
Details
Inspect-Issue is fixed-Environment Variables Datagrid view (119.37 KB, image/png)
2017-10-07 10:04 UTC, v-sukals@microsoft.com
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description v-sukals@microsoft.com 2017-01-12 05:26:13 UTC
Repro Steps:
1. Launch Visual Studio RC 2017
2. Open File+New Project+Select "Crossplatform" from the Left Pane
3. Select "Cross Platform App"."New Crossplatform" window opens
4. Select "Blank App" 
5. Press Ok button
6. Solution Window Appears at Right pane
7. Tab to the "Solution Explorer"
8. Tab to the iOS App Name(Of Ex: App2.iOS) and press Shift+F10
9. Select "Properties" option from the list. press Enter Key. App2.iOS Properties window appears 
10. Select "iOS Run Options" tab from left pane
11. Launch inspect tool
12. Using Tab navigate to "Environmental variables" table
13. Observe "Name" property of the table in inspect [Refer to screenshot "Environment Variable-Table"]

Actual Behavior:
Name property is defined as "DataGridView"

Expected Behavior:
Name property should be defined as "Environmental Variable Datagridview"


User impact:
When user select any element of the datagrid table, Screenreader reads table as "DatagridView table", actual Name of the table is different. User Rely on screen reader cannot identify name of the table.
Comment 1 v-sukals@microsoft.com 2017-01-12 05:26:41 UTC
Created attachment 19249 [details]
Inspect log
Comment 2 xamarin-release-manager 2017-09-04 14:56:51 UTC
Fixed in version 4.8.0.347 (master)

Author: Nick
Commit: 30589af5390b21b8b1159e0dd10e7eb74b34f835 (xamarin/XamarinVS)
Comment 3 v-sukals@microsoft.com 2017-09-13 11:12:30 UTC
Xamarin version 4.8.0.347 (master) is not available to verify the issue.
Comment 4 v-sukals@microsoft.com 2017-10-07 10:04:13 UTC
Created attachment 25187 [details]
Inspect-Issue is fixed-Environment Variables Datagrid view
Comment 5 v-sukals@microsoft.com 2017-10-07 10:06:46 UTC
Verified the issue and the issue is fixed - Name property is appropriate for "Environmental Variable Datagridview" datagrid, hence closing the bug.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27006.1.d15rel]
Xamarin Version: 4.8.0.559(dbde9cdd3)

Note: Please find the attachment for more info.
[Attachment: Inspect-Issue is fixed-Environment Variables Datagrid view]