Bug 51440 - Accessibility:MAS 40B:"Name" property Is empty/incorrect for Edit boxes and combo boxes in "iOS Bundle singing" tab
Summary: Accessibility:MAS 40B:"Name" property Is empty/incorrect for Edit boxes and c...
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-12 04:54 UTC by v-sukals@microsoft.com
Modified: 2017-10-07 06:04 UTC (History)
4 users (show)

See Also:
Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
Inspect and narrator buddy logs (254.46 KB, application/x-zip-compressed)
2017-01-12 05:04 UTC, v-sukals@microsoft.com
Details
Issue is fixed-Inspect and Narrator buddy Logs (862.95 KB, application/x-zip-compressed)
2017-10-07 05:57 UTC, v-sukals@microsoft.com
Details

Description v-sukals@microsoft.com 2017-01-12 04:54:24 UTC
Repro Steps:
1. Launch Visual Studio RC 2017
2. Open File+New Project+Select "Crossplatform" from the Left Pane
3. Select "Cross Platform App"."New Crossplatform" window opens
4. Select "Blank App" 
5. Press Ok button
6. Solution Window Appears at Right pane
7. Tab to the "Solution Explorer"
8. Tab to the iOS App Name(Of Ex: App2.iOS) and press Shift+F10
9. Select "Properties" option from the list. press Enter Key. App2.iOS Properties window appears 
10. Select "iOS Bundle singing" tab from left pane
11. Launch Inspect tool

Issue1:
 Observe Name property for 
"Custom entitlements" , "custom resource rules","Additional arguments" edit boxes

Issue2:
Observe Name property for "Identity" and "Provisioning profile" combo boxes in inspect

Issue3:
Observe Name property for "..." and ">" buttons.

Actual Behavior:
Issue1:
-->Name property for "Custom entitlements" edit box is defined as "Additional Arguments"
-->Name property is empty for 
"custom resource rules",Delete repeated word arguments" edit boxes

Issue2:
Name property is empty for "Identity" and "Provisioning profile" combo boxes 

Issue3:
Name property is defined as  "..." for Browse folders button
Name property is defined as ">" for  extra options button

Expected Behavior:
Name property should be defined for all the edit boxes , combo boxes and buttons


User impact:
User Rely on screenreaders cannot identify Correct Name of the Control
Comment 1 v-sukals@microsoft.com 2017-01-12 05:04:16 UTC
Created attachment 19248 [details]
Inspect and narrator buddy logs
Comment 2 Nick Sadovyi 2017-09-05 06:44:09 UTC
Fixed (master)

Author: Nick
Commit: 30589af5390b21b8b1159e0dd10e7eb74b34f835 (xamarin/XamarinVS)
Comment 3 v-sukals@microsoft.com 2017-09-13 11:05:55 UTC
Xamarin version (master) is not available to verify the bug.
Comment 4 v-sukals@microsoft.com 2017-10-07 05:57:35 UTC
Created attachment 25182 [details]
Issue is fixed-Inspect and  Narrator buddy Logs
Comment 5 v-sukals@microsoft.com 2017-10-07 06:04:14 UTC
Verified the issue and the issue is fixed - Name property is appropriate for edit boxes, combo boxes and buttons, hence closing the bug.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27005.0.d15rel]
Xamarin Version: 4.8.0.559(50450332e)

Note: Please find the attachment for more info.
[Attachment:Issue is fixed-Inspect and Narrator buddy Logs]

Note You need to log in before you can comment on or make changes to this bug.