Bug 51439 - Accessibility:MAS 40B:"Name" property is empty for edit boxes in "iOS On demand Resources" tab
Summary: Accessibility:MAS 40B:"Name" property is empty for edit boxes in "iOS On dema...
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-12 04:48 UTC by v-sukals@microsoft.com
Modified: 2017-10-06 13:37 UTC (History)
4 users (show)

Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
Inspect log (71.16 KB, image/png)
2017-01-12 04:49 UTC, v-sukals@microsoft.com
Details
Narrator buddy log (47.14 KB, image/png)
2017-01-12 04:49 UTC, v-sukals@microsoft.com
Details
Issue is fixed-Inspect and Narrator buddy Logs (244.83 KB, application/x-zip-compressed)
2017-10-06 13:34 UTC, v-sukals@microsoft.com
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description v-sukals@microsoft.com 2017-01-12 04:48:47 UTC
Repro Steps:
1. Launch Visual Studio RC 2017
2. Open File+New Project+Select "Crossplatform" from the Left Pane
3. Select "Cross Platform App"."New Crossplatform" window opens
4. Select "Blank App" 
5. Press Ok button
6. Solution Window Appears at Right pane
7. Tab to the "Solution Explorer"
8. Tab to the iOS App Name(Of Ex: App2.iOS) and press Shift+F10
9. Select "Properties" option from the list. press Enter Key. App2.iOS Properties window appears 
10. Select "iOS OnDemand Resources" tab from left pane
11. Launch inspect tool
12. Observe "Name" property of below edit boxes in the inspect
"Initial tags"
"Prefetch Order"

Actual Behavior:
Name property of "Initial tags" defined as "iOS OnDemand Resources"
Name property is empty for "Prefetch Order" edit box

Expected Behavior:
Name property should be defined as "Initial Tags"
Name property should be defined as "Prefetch Order"


User impact:
User Rely on screen readers cannot identify the Name of the edit box
Comment 1 v-sukals@microsoft.com 2017-01-12 04:49:31 UTC
Created attachment 19245 [details]
Inspect log
Comment 2 v-sukals@microsoft.com 2017-01-12 04:49:59 UTC
Created attachment 19246 [details]
Narrator buddy log
Comment 3 Nick Sadovyi 2017-09-05 06:43:53 UTC
Fixed (master)

Author: Nick
Commit: 30589af5390b21b8b1159e0dd10e7eb74b34f835 (xamarin/XamarinVS)
Comment 4 v-sukals@microsoft.com 2017-09-13 10:59:47 UTC
Xamarin Version (master) is not available to verify the issue.
Comment 5 v-sukals@microsoft.com 2017-10-06 13:34:56 UTC
Created attachment 25168 [details]
Issue is fixed-Inspect and Narrator buddy Logs
Comment 6 v-sukals@microsoft.com 2017-10-06 13:37:50 UTC
Verified the issue and the issue is fixed - Name property is appropriate for "Initial Tags" and "Pre-fetch order" edit box, hence closing the bug.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27005.0.d15rel]
Xamarin Version: 4.8.0.559(50450332e)

Note: Please find the attachment for more info.
[Attachment: Issue is fixed-Inspect and Narrator buddy logs]