Bug 51389 - Accessibility:MAS36:KB:Unable to get the context menu option using keyboard for the "Archive File".
Summary: Accessibility:MAS36:KB:Unable to get the context menu option using keyboard f...
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-11 11:11 UTC by v-sukals@microsoft.com
Modified: 2017-10-06 13:24 UTC (History)
4 users (show)

Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
KB_visualstudio_xamarin_contextmenuoption_Archivefile (292.01 KB, image/jpeg)
2017-01-11 11:11 UTC, v-sukals@microsoft.com
Details
Issue is fixed-Context menu is accessible using keyboard (76.54 KB, image/png)
2017-10-06 13:22 UTC, v-sukals@microsoft.com
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description v-sukals@microsoft.com 2017-01-11 11:11:17 UTC
Created attachment 19211 [details]
KB_visualstudio_xamarin_contextmenuoption_Archivefile

Pre-Requisite:-
1.Launch Visual Studio RC 2017
2.Open File+New Project+Select "Cross platform" from the Left Pane
3.Select "Cross Platform App"
4.Press Ok button

Steps:-
1.Run Pre-requisite
2."New Cross Platform App Window" opens
3.Tab to "Blank App" and press Enter key. New Project  will Open.
4.Navigate  to the "Solution Explorer" window using "Ctrl+Tab" key.
5.Tab to the App Name(For Ex: App2.Droid) and press Shift+F10
6.Navigate to "Archive" using down-arrow key and Press Enter Key.
7.Tab to the Archive File appears in zip format 
8.Using "Option" key or "Shift+F10" key try to get the context menu option for the archive  zip file.

Expected Result:-
User should be able to get "context menu(Delete) after pressing either "Option" key or "Shift+F10" key using keyboard.

Actual Result:-
User is unable to get any "Context" menu option after pressing "option" key or "shift+F10" key.

Platform/browser:-
OS: Windows RS1
Visual Studio Version: Visual Studio Enterprise 2017RC(15.0.25928.0)
Xamarin Version: 4.3.0.241
Comment 1 Nick Sadovyi 2017-09-11 08:05:52 UTC
Fixed in version 4.8.0.373 (master)

Author: nickolay-sadovoy
Commit: 1be1167fbd9c1c5606aee08e1445c00558ea5a3f (xamarin/XamarinVS)
Comment 2 v-sukals@microsoft.com 2017-09-19 06:59:19 UTC
Xamarin version 4.8.0.373 (master) is not available to verify the issue.
Comment 3 v-sukals@microsoft.com 2017-10-06 13:22:36 UTC
Created attachment 25166 [details]
Issue is fixed-Context menu is accessible using keyboard
Comment 4 v-sukals@microsoft.com 2017-10-06 13:24:56 UTC
Verified the issue and the issue is fixed - Able to get the context menu of archive file using keyboard, hence closing the bug.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27005.0.d15rel]
Xamarin Version: 4.8.0.559(50450332e)

Note: Please find the attachment for more info.
[Attachment: Issue is fixed-Context menu is accessible using keyboard]