Bug 51370 - Accessibility:MAS36:KB:Unable to get the context menu option for the available mac present in the "Xamarin Mac Agent" popup window.
Summary: Accessibility:MAS36:KB:Unable to get the context menu option for the availabl...
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-11 07:28 UTC by v-sukals@microsoft.com
Modified: 2017-10-07 12:47 UTC (History)
4 users (show)

See Also:
Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
KB_visualstudio_xamarin_contextmenuoption (280.16 KB, image/jpeg)
2017-01-11 07:28 UTC, v-sukals@microsoft.com
Details
Issue is fixed-Able to get the context menu using keyboard (98.75 KB, image/png)
2017-10-07 12:45 UTC, v-sukals@microsoft.com
Details

Description v-sukals@microsoft.com 2017-01-11 07:28:06 UTC
Created attachment 19187 [details]
KB_visualstudio_xamarin_contextmenuoption

Pre-Requisite:-
1.Launch Visual Studio RC 2017
2.Open File+New Project+Select "Cross platform" from the Left Pane
3.Select "Cross Platform App"
4.Press Ok button

Steps:-
1.Run Pre-requisite
2."New Cross Platform App Window" opens
3.Tab to "Blank App" and press Enter key
4.Press ALT to invoke File Menu using tab navigate to "Tools" and press Enter Key
5.Using "Enter" key select the "options". Options window opens
6.Using down arrow key navigate to "Xamarin" and Expand it.
7.Select "iOS Settings"
8.Tab to "Find Xamarin MAC Agent" button and press Enter Key
9."Xamarin MAC Agent Instructions" window opens
10.Tab to "Next" Button and press Enter Key. Xamarin MAC Agent  window opens
11.Tab to Existing MAC and Press "option", Key to get the context menu option.

Expected Result:-
User should be able to get "Context menu(Connect, Disconnect, Forget this MAC options)" using keyboard after pressing "option", key.

Actual Result:-
User is not able to get the context menu options using keyboard after pressing "option", key.

Platform/browser:-
OS: Windows RS1
Visual Studio Version: Visual Studio Enterprise 2017RC(15.0.25928.0)
Xamarin Version: 4.3.0.241
Comment 1 Nick Sadovyi 2017-09-12 07:51:46 UTC
Fixed (master)

Author: Nick
Commit: 4411d7accb1affca3e0dc48cc82330bb89e77a40 (xamarin/XamarinVS)
Comment 2 v-sukals@microsoft.com 2017-09-19 12:15:55 UTC
Xamarin version (master) is not available to verify the issue
Comment 3 v-sukals@microsoft.com 2017-10-07 12:45:40 UTC
Created attachment 25199 [details]
Issue is fixed-Able to get the context menu using keyboard
Comment 4 v-sukals@microsoft.com 2017-10-07 12:47:02 UTC
Verified the issue and the issue is fixed - Able to get the context menu using keyboard, hence closing the bug.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27006.1.d15rel]
Xamarin Version: 4.8.0.559(dbde9cdd3)

Note: Please find the attachment for more info.
[Attachment: Issue is fixed-Able to get the context menu using keyboard]

Note You need to log in before you can comment on or make changes to this bug.