Bug 51367 - Accessibility:MAS 40B:Name property is empty for edit boxes and "browse folder" button In iOS Properties-->iOS IPA Applications tab
Summary: Accessibility:MAS 40B:Name property is empty for edit boxes and "browse folde...
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-11 07:17 UTC by v-sukals@microsoft.com
Modified: 2017-10-06 12:53 UTC (History)
4 users (show)

See Also:
Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
Inspect log (94.82 KB, image/png)
2017-01-11 07:17 UTC, v-sukals@microsoft.com
Details
Narrator buddy (63.93 KB, image/png)
2017-01-11 07:17 UTC, v-sukals@microsoft.com
Details
Issue is fixed-Inspect and Narrator buddy Logs (338.14 KB, application/x-zip-compressed)
2017-10-06 12:49 UTC, v-sukals@microsoft.com
Details

Description v-sukals@microsoft.com 2017-01-11 07:17:05 UTC
Created attachment 19183 [details]
Inspect log

Repro Steps:
1. Launch Visual Studio RC 2017
2. Open File+New Project+Select "Crossplatform" from the Left Pane
3. Select "Cross Platform App"."New Crossplatform" window opens
4. Select "Blank App" 
5. Press Ok button
6. Solution Window Appears at Right pane
7. Tab to the "Solution Explorer"
8. Tab to the iOS App Name(Of Ex: App2.iOS) and press Shift+F10
9. Select "Properties" option from the list. press Enter Key. App2.iOS Properties window appears 
10. Select "iOS IPA applications" tab from left pane and select "Advanced" tab
11. Launch Inspect tool
12. Observe Name property for "iTunes Metadata" and "Package Name" edit boxes
13. Observe Name property for (...)browse button in inspect

Actual Behavior:
1. Name property for "iTunes Metadata" edit box is defined as "Optional"
2. Name property is empty for  "Package Name" edit box
3. Name property for (…)browse button is empty

Expected Behavior:
1. Name property should be defined as "iTune Metadata" and "optional" should be defined as "helpText"
2. Name property should be defined for "Package Name" edit box and "optional,by default project name" should be defined as "Help Text"
3.Name property should be defined as "browse folders" for (…) button


User impact:
User Rely on screen reader cannot identify Name of the controls
Comment 1 v-sukals@microsoft.com 2017-01-11 07:17:19 UTC
Created attachment 19184 [details]
Narrator buddy
Comment 2 Nick Sadovyi 2017-09-01 18:44:02 UTC
Fixed (master)

Author: Nick
Commit: e709557c9549eabdb984336b65763253d67ae7f5 (xamarin/XamarinVS)
Comment 3 v-sukals@microsoft.com 2017-09-13 12:43:18 UTC
Xamarin version (master) is not available to verify the bug
Comment 4 v-sukals@microsoft.com 2017-10-06 12:49:36 UTC
Created attachment 25164 [details]
Issue is fixed-Inspect and Narrator buddy Logs
Comment 5 v-sukals@microsoft.com 2017-10-06 12:53:20 UTC
Verified the issue and the issue is fixed - Name property and help text is appropriate for "iTunes Metadata" and "Package name" edit box and name property is appropriate for "Browse folders button, hence closing the bug.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27005.0.d15rel]
Xamarin Version: 4.8.0.559(50450332e)

Note: Please find the attachment for more info.
[Attachment: Issue is fixed-Inspect and Narrator buddy Logs]

Note You need to log in before you can comment on or make changes to this bug.