Bug 51364 - Accessibility:MAS 40B: "Name" properties is incorrect/empty for combo boxes in iOS Properties-->iOS build-->Advanced Tab
Summary: Accessibility:MAS 40B: "Name" properties is incorrect/empty for combo boxes i...
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-11 07:12 UTC by v-sukals@microsoft.com
Modified: 2017-10-06 12:25 UTC (History)
4 users (show)

See Also:
Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
Inspect and narrator buddy logs (228.98 KB, application/x-zip-compressed)
2017-01-11 07:12 UTC, v-sukals@microsoft.com
Details
Issue is fixed-Inspect and Narrator buddy Logs (328.92 KB, application/x-zip-compressed)
2017-10-06 12:18 UTC, v-sukals@microsoft.com
Details

Description v-sukals@microsoft.com 2017-01-11 07:12:22 UTC
Repro Steps:
1. Launch Visual Studio RC 2017
2. Open File+New Project+Select "Crossplatform" from the Left Pane
3. Select "Cross Platform App"."New Crossplatform" window opens
4. Select "Blank App" 
5. Press Ok button
6. Solution Window Appears at Right pane
7. Tab to the "Solution Explorer"
8. Tab to the iOS App Name(Of Ex: App2.iOS) and press Shift+F10
9. Select "Properties" option from the list. press Enter Key. App2.iOS Properties window appears 
10. Select "iOS Build" tab from left pane and select "Advanced" tab
11. Launch Inspect tool
12. Observe "Name" property for the below combo boxes in inspect
i)Supported architectures
ii)SSL/TLS implementation
iii)HttpClient Implementation 

Actual Behavior:
Name property for "Supported architectures" combo box is defined as "Http Client Implementation".

Name property is empty for "SSL/TLS implementation" and 
"HttpClient Implementation" combo boxes

Expected Behavior:
1. Name property should be defined as  "Supported architecture" 
2. Name property should be defined for "SSL/TLS implementation" and 
"HttpClient Implementation" combo boxes


User impact:
User Rely on screen cannot identify the Name of the control if Name property is empty
Comment 1 v-sukals@microsoft.com 2017-01-11 07:12:46 UTC
Created attachment 19182 [details]
Inspect and narrator buddy logs
Comment 2 Nick Sadovyi 2017-09-01 07:25:15 UTC
Fixed (master)

Author: Nick
Commit: deb5097b8425e22b2131d9f25a993fce62b48050 (xamarin/XamarinVS)
Comment 3 v-sukals@microsoft.com 2017-09-12 13:28:05 UTC
Xamarin version (master) is not available to verify the issue.
Comment 4 v-sukals@microsoft.com 2017-10-06 12:18:43 UTC
Created attachment 25162 [details]
Issue is fixed-Inspect and Narrator buddy Logs
Comment 5 v-sukals@microsoft.com 2017-10-06 12:25:59 UTC
Verified the issue and the issue is fixed-Name property is appropriate for "Supported Architectures"  and "HttpClient Implementation" combo box. And "SSL/TLS implementation" combo box has been removed, hence closing the bug.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27005.0.d15rel]
Xamarin Version: 4.8.0.559(50450332e)

Note: Please find the attachment for more info.
[Attachment: Issue is fixed-Inspect and Narrator buddy Logs]

Note You need to log in before you can comment on or make changes to this bug.