Bug 51363 - Accessibility:MAS05:KB:Keyboard focus is not logical in order for the "Android Setting" present in the "option" pop up window.
Summary: Accessibility:MAS05:KB:Keyboard focus is not logical in order for the "And...
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-11 07:01 UTC by v-sukals@microsoft.com
Modified: 2017-10-06 11:54 UTC (History)
4 users (show)

Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
KB_visualstudio_xamarin_optionpopupwindow (320.92 KB, image/jpeg)
2017-01-11 07:01 UTC, v-sukals@microsoft.com
Details
Issue is fixed-Keyboard focus order is appropriate in Android Settings window (80.23 KB, image/png)
2017-10-06 11:50 UTC, v-sukals@microsoft.com
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description v-sukals@microsoft.com 2017-01-11 07:01:16 UTC
Created attachment 19180 [details]
KB_visualstudio_xamarin_optionpopupwindow

Pre-Requisite:-
1.Launch Visual Studio RC 2017
2.Open File+New Project+Select "Cross platform" from the Left Pane
3.Select "Cross Platform App"
4.Press Ok button

Steps:-
1.Run Pre-requisite
2.New Cross Platform App Window" will open.
3.Using "Tab" navigate  to the "Blank App" and press Enter key to select it.
4.Press ALT to invoke File Menu using tab navigate to "Tools" and press Enter Key to select it.
5.Using "Enter" key, Select "Options".
6.Using down arrow key navigate to "Xamarin" and Expand it.
7.Using down arrow key select the  "Android Settings".
8.Using "Tab", key navigate to the different options for the Android setting.


Expected Result:-
Keyboard focus should be logical in order  while accessing the "Android Setting"  present in the "option" pop up window.

Actual Result:-
Keyboard focus  is not logical in order while accessing  "Android Setting" present in the "Option" popup window.
Note:-First the focus is moving to the "output verbosity" then to the "change" option and then to the checkboxes.

Platform/browser:-
OS: Windows RS1
Visual Studio Version: Visual Studio Enterprise 2017RC(15.0.25928.0)
Xamarin Version: 4.3.0.241
Comment 1 Nick Sadovyi 2017-09-01 07:35:28 UTC
Fixed (master)

Author: Nick
Commit: a21cd146c28ab49503a2e2f07e096bd7c205580a (xamarin/XamarinVS)
Comment 2 v-sukals@microsoft.com 2017-09-12 13:27:59 UTC
Xamarin version (master) is not available to verify the issue.
Comment 3 v-sukals@microsoft.com 2017-10-06 11:50:41 UTC
Created attachment 25156 [details]
Issue is fixed-Keyboard focus order is appropriate in Android Settings window
Comment 4 v-sukals@microsoft.com 2017-10-06 11:54:38 UTC
Verified the issue and the issue is fixed - Keyboard focus order is appropriate in Android Settings-Option pop up window, hence closing the bug.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27005.0.d15rel]
Xamarin Version: 4.8.0.559(50450332e)


Note: Please find the attached screenshot for more info.
[Screenshot: Issue is fixed-Keyboard focus order is appropriate in Android Settings window]