Bug 51362 - Accessibility:MAS40B:"Name" property is empty/incorrect for multiple elements in Android Options-->Advanced tab
Summary: Accessibility:MAS40B:"Name" property is empty/incorrect for multiple elements...
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-11 07:00 UTC by v-sukals@microsoft.com
Modified: 2017-10-06 11:06 UTC (History)
3 users (show)

See Also:
Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
Inspect and narrator buddy logs (236.80 KB, application/x-zip-compressed)
2017-01-11 07:01 UTC, v-sukals@microsoft.com
Details
Issue is fixed-Inspect and Narrator buddy Logs (269.02 KB, application/x-zip-compressed)
2017-10-06 11:01 UTC, v-sukals@microsoft.com
Details

Description v-sukals@microsoft.com 2017-01-11 07:00:24 UTC
Repro Steps:
1. Launch Visual Studio RC 2017
2. Open File+New Project+Select "Crossplatform" from the Left Pane
3. Select "Cross Platform App"."New Crossplatform" window opens
4. Select "Blank App" 
5. Press Ok button
6. Solution Window Appears at Right pane
7. Tab to the "Solution Explorer"
8. Tab to the Android App Name(Of Ex: App2.Droid) and press Shift+F10
9. Select "Properties" option from the list. press Enter Key. Properties window appears 
10. Select "Android options" from Left pane
11. Select "Advanced" tab item
12. Launch inspect tool
13. Navigate to "Java Max heap size" edit box and observe "name" property in inspect
14. Now navigate to ">" button and observe Name property in inspect
15. Navigate to "Http Client implementation" combo box and observe "name" property

Actual Behavior:
1. Name property is empty for "Java Max Heap Size" edit box
2. Name property is defined as ">"
3. Name property is defined as "Java Max Heap size" for "http client implementation combo box"

Expected Behavior:
1. Name property should be defined as "Java Max Heap Size" 
2. Name property should be defined as "Pick variables" for ">" button
3. Name property should be changed as "http client implementation"


User impact:
User Rely on screen reader cannot identify correct name of the control type
Comment 1 v-sukals@microsoft.com 2017-01-11 07:01:10 UTC
Created attachment 19179 [details]
Inspect and narrator buddy logs
Comment 2 xamarin-release-manager 2017-09-01 13:26:05 UTC
Fixed in version 4.8.0.328 (master)

Author: Nick
Commit: 19a5d38d6408a263dbbdf60b53795c5da0984d74 (xamarin/XamarinVS)
Comment 3 v-sukals@microsoft.com 2017-09-12 13:13:08 UTC
Xamarin version 4.8.0.328 (master) is not available.
Comment 4 v-sukals@microsoft.com 2017-10-06 11:01:32 UTC
Created attachment 25153 [details]
Issue is fixed-Inspect and Narrator buddy Logs
Comment 5 v-sukals@microsoft.com 2017-10-06 11:06:17 UTC
Verified the issue and the issue is fixed - Name property is appropriate for "Java Max Heap Size" edit box and "HTTPClient Implementation" combo box. And "Picker button" has been removed from the window, hence closing the bug.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27005.0.d15rel]
Xamarin Version: 4.8.0.559(50450332e)


Note: Please find the attached screenshot for more info.
[Screenshot: Issue is fixed-Inspect and Narrator buddy Logs]

Note You need to log in before you can comment on or make changes to this bug.