Bug 51359 - Accessibility:MAS 40B:Name property is not defined/incorrect for edit boxes and combo boxes in Android Properties-->Android Manifest
Summary: Accessibility:MAS 40B:Name property is not defined/incorrect for edit boxes a...
Status: CLOSED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Accessibility (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Adrian Murphy
URL:
Depends on:
Blocks:
 
Reported: 2017-01-11 06:34 UTC by v-sukals@microsoft.com
Modified: 2017-10-06 10:28 UTC (History)
4 users (show)

See Also:
Tags: a11ymas,wipro
Is this bug a regression?: ---
Last known good build:


Attachments
Inspect and narrator buddy logs (165.08 KB, application/x-zip-compressed)
2017-01-11 06:34 UTC, v-sukals@microsoft.com
Details
Issue is fixed-Inspect and Narrator buddy Logs (983.14 KB, application/x-zip-compressed)
2017-10-06 10:25 UTC, v-sukals@microsoft.com
Details

Description v-sukals@microsoft.com 2017-01-11 06:34:45 UTC
Created attachment 19175 [details]
Inspect and narrator buddy logs

Repro Steps:
1. Launch Visual Studio RC 2017
2. Open File+New Project+Select "Crossplatform" from the Left Pane
3. Select "Cross Platform App"."New Crossplatform" window opens
4. Select "Blank App" 
5. Press Ok button
6. Solution Window Appears at Right pane
7. Tab to the "Solution Explorer"
8. Tab to the App Name(Of Ex: App2.Droid) and press Shift+F10
9. Select "Properties" option from the list 10. press Enter Key. Properties window appears 
10. Select "Android Manifest" from Left pane

Issue1:
Launch Inspect tool
i)Observe Name Property for the below Edit boxes
Application name, Package Name, Application icon, Version Number, Version name and Required permissions list box

Issue2:
i)Observe Name Property for the below combo boxes
Application Icon, Install Location

Actual Behavior:
Issue1: 
Name Property is empty for 
Application name, Package Name, Application icon, Version Number, Version name edit boxes and "Required Permissions" list box

Issue2:
Name property is empty for "Install Location" combo box
Name Property is defined as "Install Location" for "Application icon" combo box



Expected Behavior:
Issue1:
Name property should be defined for all 
edit boxes

Issue2:
Name Property should be defined for "Install Location" combo box
Name Property should be changed according to the actual name of "Application icon" combo box


User impact:
User Rely on screen reader cannot identify the name of edit box/combo box if name property is empty or incorrect
User Rely on screen reader will get incorrect results if the Name property is incorrect
Comment 1 Nick Sadovyi 2017-09-01 07:22:27 UTC
Fixed (master)

Author: Nick
Commit: e67f8a5b44dddad4d636e928c23d87d48342b2bc (xamarin/XamarinVS)
Comment 2 v-sukals@microsoft.com 2017-09-12 13:11:12 UTC
Xamarin version (master) is not available.
Comment 3 v-sukals@microsoft.com 2017-10-06 10:25:34 UTC
Created attachment 25152 [details]
Issue is fixed-Inspect and Narrator buddy Logs
Comment 4 v-sukals@microsoft.com 2017-10-06 10:28:28 UTC
Verified the issue and the issue is fixed - Name property is appropriate for the edit boxes, combo boxes and list present in the window, hence closing the bug.

Verified Windows Version:
Windows 10 Pro
OS Version 1703 (OS Build 15063.608)

Verified Visual Studio Build:
Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 1.0[27005.0.d15rel]
Xamarin Version: 4.8.0.559(50450332e)

Note: Please find the attached screenshot for more info.
[Screenshot: Issue is fixed-Inspect and Narrator buddy Logs]

Note You need to log in before you can comment on or make changes to this bug.