Bug 50992 - InputTransparent applies to children on iOS but not Android.
Summary: InputTransparent applies to children on iOS but not Android.
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.3
Hardware: All All
: High normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 50362 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-12-28 03:07 UTC by David Tavárez
Modified: 2017-05-23 20:26 UTC (History)
8 users (show)

Tags: android ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description David Tavárez 2016-12-28 03:07:33 UTC
This was fixed https://bugzilla.xamarin.com/show_bug.cgi?id=35749

Now is not working.
Comment 1 Samantha Houts [MSFT] 2016-12-28 21:12:25 UTC
Thank you for taking the time to submit the bug. We tried to reproduce the issue you reported but were unable given the description. If you could please attach a reproduction to the bug by starting with a clean Xamarin.Forms project and adding just the code necessary to demonstrate the issue, we would very much appreciate it.  
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d  
 
Warm regards, 
Xamarin Forms Team
Comment 2 David Tavárez 2016-12-29 16:06:23 UTC
Code: https://github.com/davidtavarez/XFormsBug50992
Video: https://sendvid.com/7acxojt7
Comment 3 Jimmy [MSFT] 2017-01-03 17:58:45 UTC
I am able to reproduce the issue on iOS with the repro project linked in comment 2.
Comment 4 Jon Goldberger [MSFT] 2017-01-28 00:38:33 UTC
I think this is likely a dupe of https://bugzilla.xamarin.com/show_bug.cgi?id=50362

It seems to be kind of universal that InputTransparent is not working as expected on Android. 

If you create a new Forms PCL Xaml solution and replace the Label in the Xaml with:

><Grid>
>	    <DatePicker
>	        Date="2016-07-08" />
>	    <Entry
>	            Placeholder="Enter Date"
>	            TextColor="Gray"
>	            FontSize="13"
>	            HorizontalTextAlignment="Center"
>	            InputTransparent="true" />
>	</Grid>


On iOS clicking on the entry pulls up the date picker, but on Android it does not, you start editing the Entry instead. 

(Reported in SO post: http://stackoverflow.com/questions/41877614/xamarin-forms-inputtransparent-doesnt-work-on-android )
Comment 5 Samantha Houts [MSFT] 2017-02-15 18:19:23 UTC
*** Bug 50362 has been marked as a duplicate of this bug. ***
Comment 6 Jimmy [MSFT] 2017-05-23 20:26:04 UTC
I am no longer able to reproduce this issue with 2.3.5-pre3 so I am marking this as resolved.