This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 5084 - Error synchronizing changes from XCode
: Error synchronizing changes from XCode
Status: RESOLVED FIXED
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in
: 3.0.x
: Macintosh Mac OS
: Normal normal
: ---
Assigned To: Mike Krüger
:
:
:
:
  Show dependency treegraph
 
Reported: 2012-05-15 01:34 EDT by Tom Opgenorth
Modified: 2012-06-05 09:32 EDT (History)
4 users (show)

See Also:
Tags:
Test Case URL:
External Submit: ---


Attachments

Description Tom Opgenorth 2012-05-15 01:34:32 EDT
I'm editing a .storyboard file:  I double clicked on the file in MonoDevelop,
and XCode starts up. I then added three text fields, saved in XCode, and the
quit Xcode. 

Here is the stack trace for the error:

System.InvalidOperationException: Both arguments to IsDerivedFrom() must be
from the same compilation.
  at ICSharpCode.NRefactory.TypeSystem.ExtensionMethods.IsDerivedFrom
(ITypeDefinition type, ITypeDefinition baseType) [0x00029] in
/Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/contrib/ICSharpCode.NRefactory/TypeSystem/ExtensionMethods.cs:92 
  at
MonoDevelop.MacDev.ObjCIntegration.NSObjectInfoService+<GetRegisteredObjects>c__Iterator2.MoveNext
() [0x000bc] in
/Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/src/addins/MonoDevelop.MacDev/ObjCIntegration/NSObjectInfoService.cs:151 
  at MonoDevelop.MacDev.ObjCIntegration.NSObjectProjectInfo.Update () [0x0022a]
in
/Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/src/addins/MonoDevelop.MacDev/ObjCIntegration/NSObjectProjectInfo.cs:102 
  at MonoDevelop.MacDev.ObjCIntegration.NSObjectProjectInfo.Update (Boolean
force) [0x0000c] in
/Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/src/addins/MonoDevelop.MacDev/ObjCIntegration/NSObjectProjectInfo.cs:73 
  at MonoDevelop.MacDev.XcodeSyncing.XcodeSyncBackContext.get_ProjectInfo ()
[0x0002e] in
/Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/src/addins/MonoDevelop.MacDev/XcodeSyncing/XcodeSyncBackContext.cs:77 
  at
MonoDevelop.MacDev.XcodeSyncing.XcodeProjectTracker.AddCustomClassesFromUIDefinitionFiles
(IProgressMonitor monitor, MonoDevelop.MacDev.XcodeSyncing.XcodeSyncBackContext
context) [0x000d8] in
/Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/src/addins/MonoDevelop.MacDev/XcodeSyncing/XcodeProjectTracker.cs:611 
  at MonoDevelop.MacDev.XcodeSyncing.XcodeProjectTracker.SyncXcodeChanges
(IProgressMonitor monitor) [0x00069] in
/Users/builder/data/lanes/monodevelop-mac-3.0.1/6642975f/source/monodevelop/main/src/addins/MonoDevelop.MacDev/XcodeSyncing/XcodeProjectTracker.cs:464
Comment 1 Jeffrey Stedfast 2012-05-15 13:19:56 EDT
this looks like a bug in the new TypeSystem code
Comment 2 Mike Krüger 2012-05-16 03:16:13 EDT
fixed.
Comment 3 Jeffrey Stedfast 2012-05-16 13:51:55 EDT
*** Bug 5123 has been marked as a duplicate of this bug. ***
Comment 4 ramesh.sringeri 2012-05-16 13:56:21 EDT
When will the fix be available for use? Currently I had to downgrade to 2.8.8.4
Comment 5 Michael Hutchinson 2012-05-17 15:28:34 EDT
This fix has been backported, it should be released within the next few days in
3.0.2.
Comment 7 Mike Krüger 2012-06-01 06:35:26 EDT
should be fixed in master - would be nice to have a project to verify that it
works. I needed to fix it in master without use-case and I made a wrong
assumption.
(I don't know that much about the workings of the x-code roundtrip :( )
Comment 8 ramesh.sringeri 2012-06-01 07:34:59 EDT
I have resisted upgrading to 3.0.2 because 3.0 caused significant work loss.
Will upgrade and update the thread. Keeping fingers crossed.
Comment 9 ramesh.sringeri 2012-06-01 09:00:40 EDT
Unfortunately the bug fix is not working with my installation of XCode. Still
get the same exception.

Reverting back to 2.8 :-(
Comment 10 Ronald 2012-06-05 09:32:45 EDT
Just updated this morning and I get this error message when switching from
interface builder back to monodevelop. Not resolved apparently...

Note You need to log in before you can comment on or make changes to this bug.