Bug 50537 - wait_for_tids: failed to call mono_thread_detach_internal on thread 0x7000017d1000, InternalThread: 0x10c358508
Summary: wait_for_tids: failed to call mono_thread_detach_internal on thread 0x7000017...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Runtime
Classification: Mono
Component: io-layer (show other bugs)
Version: master
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-12-20 21:57 UTC by Zoltan Varga
Modified: 2017-10-06 23:22 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Zoltan Varga 2016-12-20 21:57:26 UTC
Testcase:
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

using System;
using System.Runtime.InteropServices;
using System.Threading;

class Driver
{
	[DllImport ("libc")]
	extern static void pthread_exit (IntPtr value);

	static Thread GetThread1 ()
	{
		return new Thread (() => {
			    pthread_exit (IntPtr.Zero);
		});
	}

	public static void Main ()
	{
		Thread[] threads;

		{
			threads = new Thread [] { GetThread1 (), GetThread1 () };

			for (int i = 0; i < threads.Length; ++i)
				threads [i].Start ();

			for (int i = 0; i < threads.Length; ++i)
				threads [i].Join ();
		}
	}
}
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Comment 1 Ludovic Henry 2017-10-06 23:22:29 UTC
I cannot reproduce with Mono 5.8.0.2 (2017-10/a3943e28cf8)