Bug 50190 - SGEN FPU scanning: Darwin/ARM64
Summary: SGEN FPU scanning: Darwin/ARM64
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: JIT (show other bugs)
Version: 4.8.0 (C9)
Hardware: PC Mac OS
: --- normal
Target Milestone: Future Cycle (TBD)
Assignee: Vlad Brezae
URL:
Depends on:
Blocks:
 
Reported: 2016-12-15 20:51 UTC by Andi McClure
Modified: 2017-10-19 19:35 UTC (History)
7 users (show)

Tags: bugpool-archive
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Andi McClure 2016-12-15 20:51:31 UTC
When scanning the registers+stack for an SGEN collection, we do not currently scan the FPU registers on Darwin for ARM64.

We do scan XMM registers on Darwin for Intel ( https://github.com/mono/mono/pull/4127 ). We do not have proof that FPU needs to be scanned on Darwin for ARM64, however, since Clang has been spotted using XMM registers to accelerate memcpys on Darwin/Intel32 and Darwin/Intel64, and GCC has been spotted using the FPU registers for register spilling on Linux/ARM, it is very plausible Clang is using the FPU registers on ARM64 and we just haven't caught it yet.

Because this creates high risk for hard-to-spot bugs it should be fixed for C9.
Comment 1 Rodrigo Kumpera 2016-12-15 21:01:43 UTC
Jon,

Did you apply the intel darwin fix to arm?
Comment 3 Luis Aguilera 2017-02-18 00:21:41 UTC
C9 is now closed. We'll move this bug to the next scheduled milestone, "15.1". We'll continue working on these issues, and will attempt to resolve them ASAP.
Comment 4 Andi McClure 2017-03-23 17:47:55 UTC
15.1 is shipping C9, I think this should be bumped to 15.3
Comment 5 Andi McClure 2017-03-23 17:48:08 UTC
Or rather I mean 15.1 is shipping Mono 4.8.
Comment 6 Rodrigo Kumpera 2017-06-19 15:44:14 UTC
Moving back to Ludovic to find someone to work on it.
Comment 7 Ludovic Henry 2017-09-27 22:48:13 UTC
https://github.com/mono/mono/pull/5636