Bug 49789 - Mono compilation for ARM pthread.h error
Summary: Mono compilation for ARM pthread.h error
Status: RESOLVED NORESPONSE
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: 4.8.0 (C9)
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Vladimir Kargov
URL:
Depends on:
Blocks:
 
Reported: 2016-12-13 10:33 UTC by giona.imperatori
Modified: 2018-01-24 16:24 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description giona.imperatori 2016-12-13 10:33:40 UTC
Hi,

I'm filing this bug as suggested by the compiler error message.

I'm trying to compile Mono 4.8.0.374 for ARM.
I followed the instruction found here (which seems quite old, based on 1.xx): http://www.mono-project.com/docs/about-mono/supported-platforms/arm/

Building for the host AMD64 linux (Ubuntu) machine went smoothly.
In the ARM ScratchBox I got the following error during the ./configure step

[...]
checking pthread.h presence... yes
configure: WARNING: pthread.h: present but cannot be compiled
configure: WARNING: pthread.h:     check for missing prerequisite headers?
configure: WARNING: pthread.h: see the Autoconf documentation
configure: WARNING: pthread.h:     section "Present But Cannot Be Compiled"
configure: WARNING: pthread.h: proceeding with the compiler's result
configure: WARNING:     ## ---------------------------------------------------------------------------- ##
configure: WARNING:     ## Report this to http://bugzilla.xamarin.com/enter_bug.cgi?classification=Mono ##
configure: WARNING:     ## ---------------------------------------------------------------------------- ##
checking for pthread.h... no
checking pthread_np.h usability... no
checking pthread_np.h presence... no
checking for pthread_np.h... no
checking for pthread_mutex_timedlock... no
checking for pthread_getattr_np... no
checking for pthread_attr_get_np... no
checking for pthread_setname_np... no
checking for pthread_kill... no
checking for PTHREAD_MUTEX_RECURSIVE... no
configure: error: Posix system lacks support for recursive mutexes
Comment 1 Rodrigo Kumpera 2016-12-15 21:12:14 UTC
Hey Vladimir,

Can you take a look at this one?
Comment 2 Vladimir Kargov 2016-12-15 21:49:32 UTC
Hello.

Could you specify what version of Scratchbox were you using?
Comment 3 giona.imperatori 2016-12-16 08:13:45 UTC
Hello,

I used the repo "http://scratchbox.org/debian hathor main", so I guess I got the latest version from there.
Since I was not able to proceed I purged everything from my machine, that's why I now not able to give you the exact version.
Comment 4 Ludovic Henry 2017-09-06 12:54:32 UTC
Can you still reproduce with latest version of Mono?
Comment 5 Ludovic Henry 2018-01-24 16:24:24 UTC
Please provide a reproduction case if you can still reproduce to reopen. Thank you.