Bug 48694 - Random allocation crashes in Xamarin Android Cycle 8
Summary: Random allocation crashes in Xamarin Android Cycle 8
Status: RESOLVED INVALID
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 7.0 (C8)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Vlad Brezae
URL:
Depends on:
Blocks:
 
Reported: 2016-12-02 08:12 UTC by Hieu Nhu
Modified: 2017-10-13 18:30 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
gc_alloc_vector Stacktrace (16.76 KB, text/plain)
2016-12-02 08:12 UTC, Hieu Nhu
Details
string.FastAllocateString stacktrace (23.86 KB, text/plain)
2016-12-02 08:14 UTC, Hieu Nhu
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Hieu Nhu 2016-12-02 08:12:39 UTC
Created attachment 18747 [details]
gc_alloc_vector Stacktrace

Random crashes especially after making api calls
at (wrapper managed-to-native) object.__icall_wrapper_mono_gc_alloc_vector (intptr,intptr,intptr) <0x00043>
OR
at (wrapper managed-to-native) string.FastAllocateString (int) <0x0003b>


Hi, I just updated XF to 2.3.3.168
Once in a while when calling ModernHttp component, this bug occurred. Meanwhile if it was built with Cycle 7 Visual Studio then this bug never occur. Only happens on android.

Please help me look into this as I cannot update the app with this bug to my stable releases.
Thank you in advance for the support.
Comment 1 Hieu Nhu 2016-12-02 08:14:18 UTC
Created attachment 18748 [details]
string.FastAllocateString stacktrace
Comment 2 Hieu Nhu 2016-12-02 08:18:14 UTC
This bug creation was a follow-up from Vlad Brezae request at https://bugzilla.xamarin.com/show_bug.cgi?id=11322#c21.
Is there a way to add Vlad to this thread? vlad.brezae@xamarin.com 

Thank you for your help.
Comment 3 Ashley Gazich [MSFT] 2016-12-06 22:02:14 UTC
Hello, thank you for filing this report. To help us investigate this issue, could you please include a minimized runnable test case demonstrating the crash? It would also be great to get your full version information from https://developer.xamarin.com/guides/cross-platform/troubleshooting/questions/version-logs/#version-information.
Comment 5 Mikhail Melnik 2016-12-30 21:05:43 UTC
I have the same issue. 

Generally it happens shortly after ModerHttpClient can't make a call due to absence of internet connection

[mono-rt] Stacktrace:
[mono-rt] 
[mono-rt]   at <unknown> <0xffffffff>
[mono-rt]   at (wrapper managed-to-native) string.FastAllocateString (int) <0x0003b>
[mono-rt]   at System.Text.StringBuilder.ToString () [0x00011] in /Users/builder/data/lanes/3511/501e63ce/source/mono/mcs/class/referencesource/mscorlib/system/text/stringbuilder.cs:340
[mono-rt]   at System.Text.StringBuilderCache.GetStringAndRelease (System.Text.StringBuilder) [0x00000] in /Users/builder/data/lanes/3511/501e63ce/source/mono/mcs/class/referencesource/mscorlib/system/text/stringbuildercache.cs:80
[mono-rt]   at string.Join (string,System.Collections.Generic.IEnumerable`1<string>) [0x0008b] in /Users/builder/data/lanes/3511/501e63ce/source/mono/mcs/class/referencesource/mscorlib/system/string.cs:186
[mono-rt]   at Shared.Network.RequestInfo.<logHeaders>b__15_1 (System.Linq.IGrouping`2<string, System.Collections.Generic.KeyValuePair`2<string, System.Collections.Generic.IEnumerable`1<string>>>) [0x00000] in D:\Development\Shared\Network\RequestInfo.cs:105
[mono-rt]   at System.Collections.Generic.List`1<T_REF>.ForEach (System.Action`1<T_REF>) [0x00035] in /Users/builder/data/lanes/3511/501e63ce/source/mono/mcs/class/referencesource/mscorlib/system/collections/generic/list.cs:564
Comment 6 Jon Douglas [MSFT] 2017-10-13 18:30:59 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Android. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.