Bug 48158 - Hidden controls become transparent, static property does not bind
Summary: Hidden controls become transparent, static property does not bind
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.3
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-11-28 09:30 UTC by Dale Cebula
Modified: 2016-12-08 16:10 UTC (History)
4 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Test project which recreates the transparent issue and static binding issue (218.15 KB, application/x-zip-compressed)
2016-11-28 09:30 UTC, Dale Cebula
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Dale Cebula 2016-11-28 09:30:56 UTC
Created attachment 18690 [details]
Test project which recreates the transparent issue and static binding issue

Hi,

So, looking forward to the next release of Forms (2.3.3.168) for a fix to issues with tapping off a context action in iOS I installed 2.3.3.168...

I have progress screens that are hidden until some action shows them, now they are ALL transparent no background colours get rendered for any control.

iOS - all transparent
 Android - All OK



I have a custom Renderer that no longer works and is not even called into. This now throws a null reference exception


This is caused by the following in the Xaml. This works prior to 2.3.3.168

Values="{x:Static moonviews:GradeView.All}"

Rolling back to Version 2.3.2.127 works as it always has on both iOS and Android.

Test project attached.

Thanks,

Dale
Comment 1 Rui Marinho 2016-11-28 20:06:07 UTC
https://github.com/xamarin/Xamarin.Forms/pull/570
Comment 2 Samantha Houts [MSFT] 2016-12-02 00:45:25 UTC
Should be fixed in 2.3.3-SR1. Thank you!
Comment 3 Parmendra Kumar 2016-12-08 16:10:38 UTC
I have checked this issue with Xamarin.Forms 2.3.3.175 and I am not getting any Null reference exception.

Hence closing this issue.

Thanks..!