Bug 48105 - Xamarin.Forms.Theme ResourceDictionary MergedWith fails in current build
Summary: Xamarin.Forms.Theme ResourceDictionary MergedWith fails in current build
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.3
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-11-27 04:38 UTC by TimeSlice
Modified: 2016-12-12 18:08 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Reproduction project (303.05 KB, application/zip)
2016-11-30 16:13 UTC, williamd
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description TimeSlice 2016-11-27 04:38:18 UTC
Xamarin.Forms Themes do not work when using the current public release of Xamarin forms (2.3.3.168)

All instructions were followed as per:
https://developer.xamarin.com/guides/xamarin-forms/themes/

Works fine when using Xamarin.Forms 2.3.0.38-pre2 HOWEVER after updating the solution via Nuget to the current release the application can not initialize (The app object is null) after <ResourceDictionary MergedWith="light:LightThemeResources" /> is included in the App.xaml file.
Comment 1 williamd 2016-11-30 16:13:12 UTC
Created attachment 18719 [details]
Reproduction project
Comment 2 williamd 2016-11-30 16:13:40 UTC
I added a reproduction project since I just ran into this issue as well.
Comment 3 Stephane Delcroix 2016-11-30 19:22:22 UTC
https://github.com/xamarin/Xamarin.Forms/pull/583
Comment 4 Samantha Houts [MSFT] 2016-12-02 00:36:18 UTC
Should be fixed in 2.3.3-SR1. Thank you!
Comment 6 Parmendra Kumar 2016-12-12 18:08:20 UTC
I have checked this issue with Xamarin.Forms 2.3.3.175 and this issue no longer reproducible with latest forms version.