Bug 47971 - XF UWP ListView Items no longer display ImageCell is the problem
Summary: XF UWP ListView Items no longer display ImageCell is the problem
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.3
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-11-25 15:52 UTC by Karl Shifflett
Modified: 2016-12-23 12:13 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Karl Shifflett 2016-11-25 15:52:08 UTC
Using 2.3.3.168 and XF for VS 4.2.1.64.

One of these updates has broken UWP ListView.  The items no longer display.  Last week the same simple app worked using UWP.

Items display in iOS and Android, but not UWP.

Microsoft, you need much better quality control and testing.

Real simple XAML from the Xamarin Dev Days hands on lab.

<ListView
    x:Name="ListViewSpeakers"
    SelectedItem="{Binding Path=SelectedSpeaker, Mode=TwoWay}"
    ItemsSource="{Binding Path=Speakers}">
    <ListView.ItemTemplate>
        <DataTemplate>
            <ImageCell
                Command="{Binding Path=BindingContext.SpeakerSelectedCommand, Source={x:Reference ListViewSpeakers}}"
                CommandParameter="{Binding}"
                Text="{Binding Path=Name}"
                Detail="{Binding Path=Title}"
                ImageSource="{Binding Path=Avatar}" />
        </DataTemplate>
    </ListView.ItemTemplate>
</ListView>
Comment 1 Karl Shifflett 2016-11-25 21:46:42 UTC
Found the problem.

The ImageCell is the issue.

ImageCell is broken for UWP ListView.

Verified on multiple projects.

Karl
Comment 2 E.Z. Hart [MSFT] 2016-11-29 05:31:32 UTC
The issue is not with the ImageCell. It's a problem with the Command's CanExecute method and the binding of Command, CommandParameter, and an issue with the DataTemplate temporarily inheriting the binding context of the ListView. 

I've submitted a PR: https://github.com/xamarin/Xamarin.Forms/pull/572
Comment 3 Samantha Houts [MSFT] 2016-12-02 00:41:31 UTC
Should be fixed in 2.3.3-SR1. Thank you!
Comment 4 Parmendra Kumar 2016-12-23 12:13:59 UTC
I have checked this issue with Xamarin.Forms 2.3.3.175 and followed sample code provided in bug description and I am no longer able to reproduce this issue.

Hence closing this issue.