Bug 47923 - Vectors do not work properly when used in Button.Image
Summary: Vectors do not work properly when used in Button.Image
Status: CONFIRMED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android (show other bugs)
Version: 2.3.3
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-11-24 23:08 UTC by Jim Bennett
Modified: 2017-08-03 08:17 UTC (History)
7 users (show)

See Also:
Tags: AC android vectors button
Is this bug a regression?: ---
Last known good build:


Attachments

Description Jim Bennett 2016-11-24 23:08:05 UTC
I have a Xamarin forms app that uses Vector drawables on Android and PDF vectors inside an asset catalog on iOS.

On iOS I can reference the images fine in both a Xamarin Forms Button (setting the Image property) and an Image (setting the Source property).

On Android I don't see the vector in the Image. I see it in the Button, but it is cropped oddly.

See https://github.com/jimbobbennett/FormsVectorIssue for an app that reproduces this.
Comment 1 adrianknight89 2016-11-26 18:36:38 UTC
See https://github.com/xamarin/Xamarin.Forms/pull/564 (only fixes the Image part)
Comment 2 Jim Bennett 2016-11-28 03:58:19 UTC
The poor images could be my converter... Damn you Android and your proprietary image format!

Thanks for fixing the issue. Is there a potential release version?
Comment 3 adrianknight89 2016-11-28 04:55:41 UTC
No idea. It's something that XF team will have to decide. Perhaps it could make it before 2.3.4 stable.
Comment 4 Rui Marinho 2017-02-20 15:31:27 UTC
Gonna try pull this for 2.3.5-pre1
Comment 5 Samantha Houts [MSFT] 2017-02-22 20:09:47 UTC
Should be fixed in 2.3.5-pre1. Thank you!
Comment 6 Saurabh Paunikar 2017-07-05 11:42:09 UTC
On xamarin.form version 2.3.5.256-pre6 observed that image in button is still cropped oddly.Hence reopening this issue

Screencast link: https://www.screencast.com/t/sgQCan4N

Note: On iOS both images are properly displayed
Comment 7 Jimmy [MSFT] 2017-07-12 16:15:11 UTC
As mentioned in comment 6, the vector now works as expected for an Image, however the issue with the Button.Image still exists. Therefore I've updated the report title and will keep this report open as confirmed.
Comment 8 Carlos Martínez 2017-08-03 08:17:43 UTC
Any solution or trick ?? I'm having the same problem in  2.3.5.256-pre6 .

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.