This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 47750 - Unable to update xamarin.IOS to the latest version
Summary: Unable to update xamarin.IOS to the latest version
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: General (show other bugs)
Version: unspecified
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: (C9)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-11-23 16:39 UTC by Adam Bradley
Modified: 2017-02-01 13:09 UTC (History)
8 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Adam Bradley 2016-11-23 16:39:09 UTC
Description of Problem:
Unable to update xamarin.IOS to the latest version

Steps to reproduce the problem:
1. Check for updates 
2. Apply the update


Actual Results:
2016-11-24 05:23:57.903 Xamarin Update[2412:72297] Reading index file
2016-11-24 05:23:57.905 Xamarin Update[2412:72297] Loaded 1 updates from index file
2016-11-24 05:23:57.912 Xamarin Update[2412:72372] Installing update 1 of 1
2016-11-24 05:23:57.912 Xamarin Update[2412:72372] Installing package interactively '/Users/abradley/Library/Caches/XamarinStudio-6.0/TempDownload/xamarin.ios-10.2.1.5.pkg'
2016-11-24 05:24:37.037 Xamarin Update[2412:72372] Installation appears to have failed, updateinfo value is unchanged
2016-11-24 05:24:37.043 Xamarin Update[2412:72372] Update failed to install
2016-11-24 05:24:37.043 Xamarin Update[2412:72297] Error Domain=xamarin.updater Code=-1 "Package failed to install" UserInfo={NSLocalizedDescription=Package failed to install}

Expected Results:
Success

How often does this happen? 
Every attempt

Additional Information:
Comment 1 Lluis Sanchez 2016-11-30 12:21:10 UTC
Can you please paste the about box information?

In the Xamarin Studio About box, click on Show Details and then on Copy Information, then add the information to the bug report.
Comment 2 Adam Bradley 2016-12-05 19:52:59 UTC
=== Xamarin Studio Community ===

Version 6.2 (build 1413)
Installation UUID: dfcb17f2-51e2-44b8-9241-96535d1c9818
Runtime:
	Mono 4.8.0 (mono-4.8.0-branch/f5fbc32) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 408000344

=== NuGet ===

Version: 3.4.3.0

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 8.1 (11544)
Build 8B62

=== Xamarin.Mac ===

Version: 3.0.0.290 (Xamarin Studio Community)

=== Xamarin.Android ===

Version: 7.1.0.2 (Xamarin Studio Community)
Android SDK: /Users/abradley/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.2   (API level 17)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 25.2.3
SDK Platform Tools Version: 25.0.1
SDK Build Tools Version: 23.0.2

Java SDK: /usr
java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Xamarin.iOS ===

Version: 9.1.0.27 (Xamarin Studio Community)
Hash: 1f068b4
Branch: master
Build date: 2015-10-27 18:59:21-0400

=== Xamarin Inspector ===

Version: 1.0.0.0
Hash: 1f3067d
Branch: master
Build date: 16/11/2016 7:13:59 AM

=== Build Information ===

Release ID: 602001413
Git revision: 742745078826af5470848930d858e671bb825a16
Build date: 2016-11-14 18:58:31-05
Xamarin addins: b6f6ce0cf65974359966b8da408450221780f711
Build lane: monodevelop-lion-cycle9

=== Operating System ===

Mac OS X 10.11.6
Darwin MacBook-Pro.local 15.6.0 Darwin Kernel Version 15.6.0
    Thu Jun 23 18:25:34 PDT 2016
    root:xnu-3248.60.10~1/RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

Xamarin Inspector 1.0.0.0
Comment 3 Adam Bradley 2017-01-23 23:41:18 UTC
Another attempt today fails

Jan 24 09:26:35 MacBook-Pro Installer[40281]: @(#)PROGRAM:Install  PROJECT:Install-1000
Jan 24 09:26:35 MacBook-Pro Installer[40281]: @(#)PROGRAM:Installer  PROJECT:Installer-853
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Hardware: MacBookPro11,1 @ 2.40 GHz (x 4), 8192 MB RAM
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Running OS Build: Mac OS X 10.11.6 (15G31)
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: TMPDIR=/var/folders/24/_kh66q313yjgh4ggh2359b6m0000gp/T/
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: MONODEVELOP_64BIT_SAFE=yes
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: LC_NUMERIC=C
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: __CF_USER_TEXT_ENCODING=0x1F6:0x0:0xF
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: HOME=/Users/abradley
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: SHELL=/bin/bash
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: Apple_PubSub_Socket_Render=/private/tmp/com.apple.launchd.ChJVqUWi1d/Render
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: SSH_AUTH_SOCK=/private/tmp/com.apple.launchd.LDD2xTEQnf/Listeners
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: PATH=/Library/Frameworks/Mono.framework/Commands:/Applications/Xamarin Studio.app/Contents/Resources:/Applications/Xamarin Studio.app/Contents/MacOS:/usr/bin:/bin:/usr/sbin:/sbin
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: LOGNAME=abradley
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: XPC_SERVICE_NAME=com.apple.installer.672.2EE6B731-6042-4945-848A-715C67284CFB
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: COMMAND_MODE=unix2003
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: LANGUAGE=en
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: USER=abradley
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: MONO_GAC_PREFIX=/Applications/Xamarin Studio.app/Contents/Resources
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: XPC_FLAGS=0x0
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: XCODE_DEVELOPER_DIR_PATH=/Applications/Xcode.app/Contents/Developer
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: MONODEVELOP_STUB_LANGUAGE=en
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Env: PKG_CONFIG_PATH=/Applications/Xamarin Studio.app/Contents/Resources/lib/pkgconfig:/Library/Frameworks/Mono.framework/External/pkgconfig
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Xamarin.iOS  Installation Log
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Opened from: /Users/abradley/Library/Caches/XamarinStudio-6.0/TempDownload/xamarin.ios-10.4.0.88.pkg
Jan 24 09:26:35 MacBook-Pro Installer[40281]: Product archive /Users/abradley/Library/Caches/XamarinStudio-6.0/TempDownload/xamarin.ios-10.4.0.88.pkg trustLevel=202
Jan 24 09:26:41 MacBook-Pro Installer[40281]: InstallerStatusNotifications plugin loaded
Jan 24 09:26:45 MacBook-Pro Installer[40281]: LSExceptions [0x7fe84a519dc0] unloaded
Jan 24 09:26:45 MacBook-Pro Installer[40281]: Administrator authorization granted.
Jan 24 09:26:45 MacBook-Pro Installer[40281]: ================================================================================
Jan 24 09:26:45 MacBook-Pro Installer[40281]: User picked Standard Install
Jan 24 09:26:45 MacBook-Pro Installer[40281]: Choices selected for installation:
Jan 24 09:26:45 MacBook-Pro Installer[40281]: 	Upgrade: "Xamarin.iOS"
Jan 24 09:26:45 MacBook-Pro Installer[40281]: 	Upgrade: "Install Xamarin.iOS"
Jan 24 09:26:45 MacBook-Pro Installer[40281]: 		xamarin.ios-10.4.0.88.pkg#monotouch.pkg : com.xamarin.monotouch.pkg : 1
Jan 24 09:26:45 MacBook-Pro Installer[40281]: 	Upgrade: "Remove Xamarin.iOS Build host for Visual Studio"
Jan 24 09:26:45 MacBook-Pro Installer[40281]: 		xamarin.ios-10.4.0.88.pkg#delete-xma-build-host.pkg : com.xamarin.xamarin-ios-build-host.pkg : 1
Jan 24 09:26:45 MacBook-Pro Installer[40281]: ================================================================================
Jan 24 09:26:45 MacBook-Pro Installer[40281]: It took 0.00 seconds to summarize the package selections.
Jan 24 09:26:45 MacBook-Pro Installer[40281]: -[IFDInstallController(Private) _buildInstallPlanReturningError:]: location = file://localhost
Jan 24 09:26:45 MacBook-Pro Installer[40281]: -[IFDInstallController(Private) _buildInstallPlanReturningError:]: file://localhost/Users/abradley/Library/Caches/XamarinStudio-6.0/TempDownload/xamarin.ios-10.4.0.88.pkg#monotouch.pkg
Jan 24 09:26:45 MacBook-Pro Installer[40281]: -[IFDInstallController(Private) _buildInstallPlanReturningError:]: file://localhost/Users/abradley/Library/Caches/XamarinStudio-6.0/TempDownload/xamarin.ios-10.4.0.88.pkg#delete-xma-build-host.pkg
Jan 24 09:26:45 MacBook-Pro Installer[40281]: Set authorization level to root for session
Jan 24 09:26:45 MacBook-Pro Installer[40281]: Will use PK session
Jan 24 09:26:45 MacBook-Pro Installer[40281]: Using authorization level of root for IFPKInstallElement
Jan 24 09:26:46 MacBook-Pro Installer[40281]: Starting installation:
Jan 24 09:26:46 MacBook-Pro Installer[40281]: Configuring volume "Macintosh HD"
Jan 24 09:26:46 MacBook-Pro Installer[40281]: Preparing disk for local booted install.
Jan 24 09:26:46 MacBook-Pro Installer[40281]: Free space on "Macintosh HD": 3.24 GB (3236753408 bytes).
Jan 24 09:26:46 MacBook-Pro Installer[40281]: Create temporary directory "/var/folders/24/_kh66q313yjgh4ggh2359b6m0000gp/T//Install.40281UuohSr"
Jan 24 09:26:46 MacBook-Pro Installer[40281]: IFPKInstallElement (2 packages)
Jan 24 09:26:46 MacBook-Pro installd[2317]: PackageKit: Adding client PKInstallDaemonClient pid=40281, uid=502 (/System/Library/CoreServices/Installer.app/Contents/MacOS/Installer)
Jan 24 09:26:46 MacBook-Pro Installer[40281]: PackageKit: Enqueuing install with framework-specified quality of service (utility)
Jan 24 09:26:46 MacBook-Pro installd[2317]: PackageKit: ----- Begin install -----
Jan 24 09:26:46 MacBook-Pro installd[2317]: PackageKit: request=PKInstallRequest <2 packages, destination=/>
Jan 24 09:26:46 MacBook-Pro installd[2317]: PackageKit: packages=(
	    "PKLeopardPackage <file://localhost/Users/abradley/Library/Caches/XamarinStudio-6.0/TempDownload/xamarin.ios-10.4.0.88.pkg#monotouch.pkg>",
	    "PKLeopardPackage <file://localhost/Users/abradley/Library/Caches/XamarinStudio-6.0/TempDownload/xamarin.ios-10.4.0.88.pkg#delete-xma-build-host.pkg>"
	)
Jan 24 09:26:46 MacBook-Pro installd[2317]: PackageKit: Will do receipt-based obsoleting for package identifier com.xamarin.xamarin-ios-build-host.pkg (prefix path=)
Jan 24 09:26:48 MacBook-Pro installd[2317]: PackageKit: Extracting file://localhost/Users/abradley/Library/Caches/XamarinStudio-6.0/TempDownload/xamarin.ios-10.4.0.88.pkg#monotouch.pkg (destination=/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/F2C13DF4-48B0-4BBC-9BB1-A19F6872CD66.activeSandbox/Root, uid=0)
Jan 24 09:26:54 MacBook-Pro installd[2317]: PackageKit: Extracting file://localhost/Users/abradley/Library/Caches/XamarinStudio-6.0/TempDownload/xamarin.ios-10.4.0.88.pkg#delete-xma-build-host.pkg (destination=/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/F2C13DF4-48B0-4BBC-9BB1-A19F6872CD66.activeSandbox/Root, uid=0)
Jan 24 09:26:54 MacBook-Pro installd[2317]: PackageKit: prevent user idle system sleep
Jan 24 09:26:54 MacBook-Pro installd[2317]: PackageKit: suspending backupd
Jan 24 09:26:54 MacBook-Pro installd[2317]: PackageKit: Executing script "./preinstall" in /private/tmp/PKInstallSandbox.qeTqs9/Scripts/com.xamarin.xamarin-ios-build-host.pkg.hsUjeU
Jan 24 09:26:54 MacBook-Pro install_monitor[40294]: Temporarily excluding: /Applications, /Developer, /Library, /System, /bin, /private, /sbin, /usr
Jan 24 09:26:55 MacBook-Pro installd[2317]: ./preinstall: rm: /Library/LaunchAgents/com.xamarin.mtvs.buildserver.plist: Not a directory
Jan 24 09:26:55 MacBook-Pro installd[2317]: ./preinstall: rm: /Library/LaunchAgents/com.xamarin.mtvs.buildservergui.plist: Not a directory
Jan 24 09:26:55 MacBook-Pro install_monitor[40294]: Re-included: /Applications, /Developer, /Library, /System, /bin, /private, /sbin, /usr
Jan 24 09:26:55 MacBook-Pro installd[2317]: PackageKit: releasing backupd
Jan 24 09:26:55 MacBook-Pro installd[2317]: PackageKit: allow user idle system sleep
Jan 24 09:26:55 MacBook-Pro installd[2317]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “xamarin.ios-10.4.0.88.pkg”." UserInfo={NSFilePath=./preinstall, NSURL=file://localhost/Users/abradley/Library/Caches/XamarinStudio-6.0/TempDownload/xamarin.ios-10.4.0.88.pkg#delete-xma-build-host.pkg, PKInstallPackageIdentifier=com.xamarin.xamarin-ios-build-host.pkg, NSLocalizedDescription=An error occurred while running scripts from the package “xamarin.ios-10.4.0.88.pkg”.} {
	    NSFilePath = "./preinstall";
	    NSLocalizedDescription = "An error occurred while running scripts from the package \U201cxamarin.ios-10.4.0.88.pkg\U201d.";
	    NSURL = "file://localhost/Users/abradley/Library/Caches/XamarinStudio-6.0/TempDownload/xamarin.ios-10.4.0.88.pkg#delete-xma-build-host.pkg";
	    PKInstallPackageIdentifier = "com.xamarin.xamarin-ios-build-host.pkg";
	}
Jan 24 09:26:55 MacBook-Pro Installer[40281]: install:didFailWithError:Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “xamarin.ios-10.4.0.88.pkg”." UserInfo={NSFilePath=./preinstall, NSURL=file://localhost/Users/abradley/Library/Caches/XamarinStudio-6.0/TempDownload/xamarin.ios-10.4.0.88.pkg#delete-xma-build-host.pkg, PKInstallPackageIdentifier=com.xamarin.xamarin-ios-build-host.pkg, NSLocalizedDescription=An error occurred while running scripts from the package “xamarin.ios-10.4.0.88.pkg”.}
Jan 24 09:26:55 MacBook-Pro installd[2317]: PackageKit: Removing client PKInstallDaemonClient pid=40281, uid=502 (/System/Library/CoreServices/Installer.app/Contents/MacOS/Installer)
Jan 24 09:26:55 MacBook-Pro installd[2317]: PackageKit: Running idle tasks
Jan 24 09:26:55 MacBook-Pro Installer[40281]: Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.
Jan 24 09:26:55 MacBook-Pro Installer[40281]: IFDInstallController 4A524E80 state = 8
Jan 24 09:26:55 MacBook-Pro Installer[40281]: Displaying 'Install Failed' UI.
Jan 24 09:26:55 MacBook-Pro Installer[40281]: 'Install Failed' UI displayed message:'The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.'.
Jan 24 09:26:56 MacBook-Pro installd[2317]: PackageKit: Done with sandbox removals
Comment 4 iain 2017-01-25 15:48:03 UTC
This looks like an error with the actual xamarin.ios package file, the output is from the macOS installer application which is creating an error.

It looks like the package is failing with something to do with deleting the xma build host?

Reassigning to xamarin.ios for them to investigate their package.
Comment 5 iain 2017-01-25 15:49:00 UTC
I'll ping release engineering as well.
Comment 6 Rolf Bjarne Kvinge 2017-01-25 17:27:45 UTC
@Adam, if this is still a problem, can you do the following:

* Download https://gist.github.com/rolfbjarne/59342e89015004c466ddd386d3029d14 locally to a file named "preinstall.sh"
* Execute "chmod +x preinstall.sh"
* Execute "./preinstall.sh; echo $?"

and then paste the output here?
Comment 7 Sebastien Pouliot 2017-01-27 14:41:57 UTC
@Gouri can you try to duplicate this update path and see if you can duplicate it ? thanks!
Comment 10 Rolf Bjarne Kvinge 2017-01-31 06:15:57 UTC
Fixed (I think): https://github.com/xamarin/xamarin-macios/commit/7bfe13396e2142cfb79a515b5ce4b59ed025900d

@Sebastien, do you want this fix back ported to C9?
Comment 11 Rolf Bjarne Kvinge 2017-01-31 06:33:25 UTC
@Sebastien, I just saw your comment here: https://github.com/xamarin/xamarin-macios/pull/1587#pullrequestreview-19165686

So C9 PR: https://github.com/xamarin/xamarin-macios/pull/1590
Comment 12 Sebastien Pouliot 2017-01-31 13:42:45 UTC
@Gouri, it's not critical and I believe Rolf fix will solve this. However I'd like you to try one last time :)

The only difference would be to install the old version with user X
and then to upgrade to the new version with user Y

thanks!
Comment 13 GouriKumari 2017-01-31 20:52:47 UTC
>>@Gouri, it's not critical and I believe Rolf fix will solve this. However I'd like you to try one last time :). 
The only difference would be to install the old version with user X
and then to upgrade to the new version with user Y

I couldn't reproduce the issue following the above steps. I downloaded and installed old version of iOS in user Y (standard) account with user X (admin account) and then upgraded to latest alpha using user Y (after giving admin privileges).
Comment 14 Sebastien Pouliot 2017-01-31 20:56:02 UTC
@Adam we believe the issue to be fixed (see comment #11) but we were not able to duplicate it ourselves.

If you can try again with the next refresh (should be next week) and let us know the result it would be much appreciated. If it does not work please see if you can try what Rolf mentioned in comment #6. Thanks!
Comment 15 Danish Akhtar 2017-02-01 13:09:40 UTC
I am also not able to reproduce this issue with XS build mentioned in Comment 2.

Also checked with latest C9 builds and observed that I am successfully able to install Alpha X.iOS 10.4.0.97.

@Adam, As of now I am closing this issue. Please feel free to reopen it, If you Encountered this issue again with next refresh build.

Env info: 
https://gist.github.com/danish360/8a986f3037fbd0bf77fd06e4ef21a182

Thanks!

Note You need to log in before you can comment on or make changes to this bug.