Bug 47601 - AVAssetImageGenerator.ApertureMode{more} should be enum
Summary: AVAssetImageGenerator.ApertureMode{more} should be enum
Status: CONFIRMED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll (show other bugs)
Version: XI 10.0 (iOS10)
Hardware: PC Mac OS
: Normal enhancement
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-11-21 20:59 UTC by Larry O'Brien
Modified: 2016-11-22 13:22 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 47601 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Larry O'Brien 2016-11-21 20:59:28 UTC
AVAssetImageGenerator.ApertureMode is a string that, if not null, must be one of the values: AVAssetImageGenerator.ApertureModeCleanAperture, .ApertureModeEncodedPixels, .ApertureModeProductionAperture 

These values should be in an enum
Comment 1 Vincent Dondain [MSFT] 2016-11-22 13:22:09 UTC
Hi Larry,

That's a valid request but we'll need to think about it and come up with a good name for the smarter version of `ApertureMode` (we cannot remove or update this one as it would be a breaking change).

I'm marking it as CONFIRMED, however this does not necessarily mean we will take actions on it as we still need to discuss its feasibility internally.