Bug 47552 - Mono does not work with grsec after install.
Summary: Mono does not work with grsec after install.
Status: NEW
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-11-20 18:00 UTC by fanthos
Modified: 2017-05-16 16:30 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description fanthos 2016-11-20 18:00:01 UTC
I am using Mono with Grsec kernel patch on Debian Jessie, Mono does not work as default. I have to manually configure Grsec to disable mprotect using:
paxctl -v /usr/bin/mono-sgen
paxctl -m /usr/bin/mono-sgen
after every time I upgraded mono-sgen binary.

Is it possible to disable mprotect if grsec is enabled after package installed?

ref:
http://gentoo-en.vfose.ru/wiki/Mono

Note You need to log in before you can comment on or make changes to this bug.