Bug 47295 - [UWP] Toolbar is Clipped When Using a NavigationPage
Summary: [UWP] Toolbar is Clipped When Using a NavigationPage
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows (show other bugs)
Version: 2.3.3
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 47716 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-11-17 22:45 UTC by Jimmy [MSFT]
Modified: 2016-12-07 12:06 UTC (History)
4 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
repro project (230.37 KB, application/zip)
2016-11-17 22:45 UTC, Jimmy [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Jimmy [MSFT] 2016-11-17 22:45:04 UTC
Created attachment 18521 [details]
repro project

### Overview
The CommandBar on UWP is experiencing some issues introduced in Forms 2.3.3 when inside a NavigationPage. On the desktop when it is expanded the Label for primary commands is clipped. 

On mobile, the Labels are clipped and the CommandBar is also overlaying the page content. And if there are no secondary commands, the "..." button isn't visible.


### Steps to Reproduce
1. Run the attached UWP on a PC or phone
2. Press the "..." button on the CommandBar


### Expected Results
The Label text for the primary command is completely visible


### Actual Results
The Label is clipped


### Testing Info
The issue appeared in Forms 2.3.3
Comment 1 Jimmy [MSFT] 2016-11-30 18:47:52 UTC
See PR: https://github.com/xamarin/Xamarin.Forms/pull/582
Comment 2 Samantha Houts [MSFT] 2016-11-30 19:09:41 UTC
*** Bug 47716 has been marked as a duplicate of this bug. ***
Comment 3 Parmendra Kumar 2016-12-07 12:06:04 UTC
I have checked this issue with Xamarin.Forms 2.3.3.175 and its working fine.

Hence closing this issue.


Thanks.