Bug 4725 - M4A Debugger exits silently without exceptions
Summary: M4A Debugger exits silently without exceptions
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger (show other bugs)
Version: 4.1.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 2945 5801 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-30 01:43 UTC by Paul DB
Modified: 2012-06-29 19:09 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test Case (19.64 KB, application/octet-stream")
2012-06-13 16:03 UTC, Jonathan Pobst
Details

Description Paul DB 2012-04-30 01:43:21 UTC
I have experienced this issue before with other projects, but it is now a consistent problem with the work I am doing on the Caulker project.

I am debugging the app on my device (Samsung Galaxy S2), using Visual Studio 2010.

To repo the issue, grab the code from my Github and run the demo project.

https://github.com/pauldbau/caulker

Within 5 - 30 seconds of the app starting, the debugger dies silently.  Nothing shows in the Android adb trace except the "Window died" messages.

I suspect it may have something to do with the threading involved in the tile downloads.
The other projects where this debugger issue has happened also involve Http requests in asynch (multi-threaded) scenarios.

Note: the app generally runs fine directly off the phone (i.e. without debugger).
Comment 1 Jonathan Pobst 2012-04-30 15:30:48 UTC
I cannot reproduce this on my Nexus One.  I'll ask around and see if someone has a Samsung device that can try this to see if it's device specific.

If you want to help narrow it down further, you can comment out pieces of your thread code until it stops crashing.
Comment 2 Jonathan Pobst 2012-06-13 16:03:37 UTC
Created attachment 2051 [details]
Test Case

Here's a test case that allows me to reproduce this in Visual Studio 2010 with my Nexus One.
Comment 8 Jonathan Pobst 2012-06-14 20:02:00 UTC
Fixed for 4.2.4.

Thanks for the report!

a477de4aa478a09b34a84feee4f8d25a50dacdd3
Comment 9 Jonathan Pobst 2012-06-14 20:02:49 UTC
*** Bug 2945 has been marked as a duplicate of this bug. ***
Comment 10 Mikayla Hutchinson [MSFT] 2012-06-29 19:09:03 UTC
*** Bug 5801 has been marked as a duplicate of this bug. ***

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 4725 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: