Bug 47203 - Remove WeakReference IsAlive true references in XF source code
Summary: Remove WeakReference IsAlive true references in XF source code
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.3
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-11-17 17:18 UTC by adrianknight89
Modified: 2016-11-26 20:02 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description adrianknight89 2016-11-17 17:18:31 UTC
When using WeakReferences, one should be careful to not rely on IsAlive = true. If this property returns false, then the object has been GC'ed for sure. If it returns true, however, it could either be alive with a strong reference or marked for garbage collection.

There are several places in XF source code where IsAlive is used when it is true. In my opinion, these should be fixed and you should probably create some kind of VS macro to guard against future mistakes. 

https://msdn.microsoft.com/en-us/library/system.weakreference.isalive(v=vs.110).aspx
https://blogs.msdn.microsoft.com/clyon/2006/04/20/why-you-shouldnt-rely-on-weakreference-isalive/
https://csharp.2000things.com/2012/12/13/735-dont-trust-weakreference-isalive-if-it-returns-true/
Comment 1 adrianknight89 2016-11-17 17:24:47 UTC
That said, there might be true use cases when IsAlive is true and you want to run some kind of code before an object is GC'ed. However, this seems to be more of an edge case than just checking the Target property.
Comment 2 adrianknight89 2016-11-24 04:37:31 UTC
https://github.com/xamarin/Xamarin.Forms/pull/558

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 47203 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: