Bug 46938 - Toolbar Subtitle Reset When Screen Rotated
Summary: Toolbar Subtitle Reset When Screen Rotated
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android (show other bugs)
Version: 2.3.3
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-11-14 17:27 UTC by Jimmy [MSFT]
Modified: 2016-11-25 09:19 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
repro project (710.63 KB, application/zip)
2016-11-14 17:27 UTC, Jimmy [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Jimmy [MSFT] 2016-11-14 17:27:58 UTC
Created attachment 18453 [details]
repro project

### Overview
The Toolbar subtitle text set via a custom NavigationPage renderer is removed when the screen orientation changes. This happens because the Toolbar is reset every time OnLayout() is called: https://github.com/xamarin/Xamarin.Forms/blob/master/Xamarin.Forms.Platform.Android/AppCompat/NavigationPageRenderer.cs#L282


### Steps to Reproduce 
1. Run the attached Android project
2. Rotate the device/emulator


### Expected Results
The subtitle text will remain.


### Actual Results
The Toolbar subtitle text will disappear.


### Workaround
You can detect when the Height or Width changes in OnElementPropertyChanged() which should indicate an orientation change and call SetSubtitle() again.


### Testing Info
Tested with Forms 2.3.2 and 2.3.3-pre3
Comment 1 adrianknight89 2016-11-14 23:31:55 UTC
See https://github.com/xamarin/Xamarin.Forms/pull/528
Comment 2 Samantha Houts [MSFT] 2016-11-16 20:49:01 UTC
Should be fixed in 2.3.4-pre1. Thank you!
Comment 3 Parmendra Kumar 2016-11-25 09:19:42 UTC
I have checked this issue with Xamarin.Forms 2.3.4-pre1 and observed that this issue has been fixed.

Hence closing this issue.


Thanks.