Bug 4682 - There is a conflict with Couchdb and the debugger
Summary: There is a conflict with Couchdb and the debugger
Status: RESOLVED ANSWERED
Alias: None
Product: iOS
Classification: Xamarin
Component: General (show other bugs)
Version: 5.2
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-04-26 19:29 UTC by James Clancey
Modified: 2016-02-15 15:56 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description James Clancey 2012-04-26 19:29:00 UTC
Couchdb loads its own internal server. Whenever it launches you are unable to debug MonoTouch projects. You can run the attached sample in debug mode and the debugger fails. If you run the app it works great.
Comment 1 James Clancey 2012-04-26 19:33:10 UTC
Testcase: http://dl.dropbox.com/u/49675167/CouchDb.zip
Comment 2 Jeffrey Stedfast 2012-06-04 17:16:55 UTC
it looks like couchdb is closing the socket connection between MonoDevelop and the app, probably when it forks off the server.
Comment 4 Jeffrey Stedfast 2012-06-05 10:51:05 UTC
MonoDevelop can't override CouchDB closing socket descriptors in the app.

I haven't closed this bug yet because I'm trying to think of ways that MonoTouch could prevent CouchDB from going behind its back and closing socket descriptors, but I haven't thought of any way to do that yet...

Speaking of which, I should reassign this to the MonoTouch team as it's clearly impossible to workaround in MonoDevelop.
Comment 5 Rolf Bjarne Kvinge [MSFT] 2016-02-15 15:56:32 UTC
The test case from comment #1 is gone (404), so I'm not able to reproduce this.

In any case from Jeff's diagnosis it doesn't sound like a bug in our products.

Please reopen (attaching a test project) if this is still an issue.