Bug 46806 - opspecial011.Program.DynamicCSharpRunTest test in ms-test-suite fails with "Operator '+' cannot be applied to operands"
Summary: opspecial011.Program.DynamicCSharpRunTest test in ms-test-suite fails with "O...
Status: RESOLVED FIXED
Alias: None
Product: Compilers
Classification: Mono
Component: C# (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2016-11-11 15:31 UTC by Alexander Köplinger [MSFT]
Modified: 2016-11-17 17:51 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Alexander Köplinger [MSFT] 2016-11-11 15:31:30 UTC
Stacktrace:


> 1) DynamicCSharpRunTest > (ManagedTests.DynamicCSharp.Conformance.dynamic.SpecialNames.opspecial011.Program.DynamicCSharpRunTest)
>    Microsoft.CSharp.RuntimeBinder.RuntimeBinderException : Operator `+' cannot be applied to operands of type > `ManagedTests.DynamicCSharp.Conformance.dynamic.SpecialNames.opspecial011.Test' and `int'
>   at (wrapper dynamic-method) System.Object:CallSite.Target (System.Runtime.CompilerServices.Closure,> System.Runtime.CompilerServices.CallSite,object,int)
>   at System.Dynamic.UpdateDelegates.UpdateAndExecute2[T0,T1,TRet] (System.Runtime.CompilerServices.CallSite site, T0 arg0, > T1 arg1) [0x00132] in > /Users/alexander/dev/mono/mcs/class/dlr/Runtime/Microsoft.Scripting.Core/Actions/UpdateDelegates.Generated.cs:387
>   at ManagedTests.DynamicCSharp.Conformance.dynamic.SpecialNames.opspecial011.Test.Method () [0x002ee] in > /Users/alexander/dev/mono/acceptance-tests/external/ms-test-suite/conformance/System.Dynamic.Runtime/4.0.0.0/Dynamic.> Other/Conformance.dynamic.SpecialNames.cs:388
>   at (wrapper dynamic-method) System.Object:CallSite.Target (System.Runtime.CompilerServices.Closure,> System.Runtime.CompilerServices.CallSite,object)
>   at System.Dynamic.UpdateDelegates.UpdateAndExecute1[T0,TRet] (System.Runtime.CompilerServices.CallSite site, T0 arg0) > [0x00127] in > /Users/alexander/dev/mono/mcs/class/dlr/Runtime/Microsoft.Scripting.Core/Actions/UpdateDelegates.Generated.cs:262
>   at ManagedTests.DynamicCSharp.Conformance.dynamic.SpecialNames.opspecial011.Program.MainMethod () [0x00010] in > /Users/alexander/dev/mono/acceptance-tests/external/ms-test-suite/conformance/System.Dynamic.Runtime/4.0.0.0/Dynamic.> Other/Conformance.dynamic.SpecialNames.cs:407
>   at ManagedTests.DynamicCSharp.Conformance.dynamic.SpecialNames.opspecial011.Program.DynamicCSharpRunTest () [0x00002] in > /Users/alexander/dev/mono/acceptance-tests/external/ms-test-suite/conformance/System.Dynamic.Runtime/4.0.0.0/Dynamic.> Other/Conformance.dynamic.SpecialNames.cs:401
>   at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],> System.Exception&)
>   at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, > System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00038] in > /Users/alexander/dev/mono/mcs/class/corlib/System.Reflection/MonoMethod.cs:305

This test was never ran on NUnit because it ignored it, but showed up with the move to nunitlite.
Comment 1 Marek Safar 2016-11-17 17:51:03 UTC
Fixed in master

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 46806 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: