Bug 46458 - Grid.IsEnabled property is not working
Summary: Grid.IsEnabled property is not working
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-11-04 10:15 UTC by Ashok
Modified: 2017-07-13 06:20 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample with Grid.IsEnabled is False (297.61 KB, application/x-zip-compressed)
2016-11-04 10:15 UTC, Ashok
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Ashok 2016-11-04 10:15:31 UTC
Created attachment 18327 [details]
Sample with Grid.IsEnabled is False

I have Grid.IsEnabled property value is False and loaded some controls within Grid but that controls are enabled only. I can able to interact with that controls.

Expect behavior is need to disable the controls and no interaction with that child elements. 

I have attached sample by loading Entry and Button within Grid and Grid.IsEnabled is False but Entry edit and Button.Clicked events are fired.
Comment 1 adrianknight89 2016-11-04 17:19:23 UTC
Were you having this issue only on Android? What about other platforms?

See https://github.com/xamarin/Xamarin.Forms/pull/483
Comment 2 Ashok 2016-11-15 12:17:02 UTC
Hi,

We have tested reported issue in all platform and issue reproduced in Android and Windows platforms only. It was working properly in iOS.

Thanks,
Ashok
Comment 3 Jimmy [MSFT] 2017-02-23 18:59:21 UTC

*** This bug has been marked as a duplicate of bug 44096 ***
Comment 4 Ashok 2017-03-07 07:19:32 UTC
Hi Team,

Linked duplicate bug is not fixed yet so i reopen this bug.

Thanks,
Ashok
Comment 5 Rui Marinho 2017-03-23 17:27:20 UTC
Should be fixed on 2.3.5-pre1.
Comment 6 Aman Dharwal 2017-07-13 06:20:07 UTC
Verified on xamarin.form version 2.3.5.256-pre6. Verified on both android and UWP

ScreenCast link: https://www.screencast.com/t/YCwzSGBnMF